Problems accessing any Comodo sites


I have a weird issue here. I am having trouble accessing any site from Comodo, main, support, forums etc… Through win 7. Ive tried 3 browsers (IE8, Chrome, Firefox) but they all timeout. If I launch XP Virtual mode the sites load up fine and im able to log in (how im accessing right now) Right now were connected to our local domain and any xp based computer can access the comodo sites from our testing but any win7 based computers cannot and result in timeouts or says dnserror. Ive checked the network and nothing is blocked, cleared temp files, played around with browser security settings and still the same issue persists.
Another thing is if I tether any win 7 pc through my phone, or run behind a proxy site it works fine. Im at a loss here since there is no policy to block sites other than the usual social networking sites and its only happening on win 7 based pc’s.


Can you access or ?

No, it just times out whenever im in 7 & the network connection. I am able to access it through the virtual xp pc thats installed on it with the same domain. ???