Problematic install for v3.0.12.266 & (x86)

I uninstalled v2.4 and did a reboot, cleaned up some of the leftover registry entries manually (wish that cleanup script was searchable on here) and then rebooted again.

Now I proceeded to install the firewall, opting to install the Basic (as I only want the firewall, no Defense+). So I get it installed, following the prompt to reboot. Reboot happens and I’m now back into Windows. There is no Comodo icon in the systray, and I’m getting both firewall alerts and Defense+ alerts. This stuck me as odd, considering I told the installer to only install the firewall. Comodo itself lags and tends to report an error, but even the error reporting service of Comodo’s lags and crashes. Both cpf and the reporter program cause dwwin.exe (Doctor Watson) and even the Error Reporting service to hang.

I also verified the MD5 and it matches, so I know it’s not a bad download. It has occured with both and

Windows XP SP2 with all updates
3.4GHz P4 with HyperThreading
No other security software running real-time.

Anyone else had this problem? Help is welcome.

Try running Miscellaneous>Diagnostics to see if the install is ok.

Tried that, it reported the install was fine.

Still no tray icon? Have you tried running cfp.exe again to see if it gives you a tray icon? If you can’t see a tray icon, you can’t get at any of the program settings. If this continues, you should uninstall it and try again. Did you by chance install it in safe mode? That has been known to cause problems.

I have tried various methods of installing it, with and without Defense+. I don’t install programs in Safe Mode, tend to avoid that unless absolutely necessary.

Running cpf.exe will not show the program window or tray icon. However, I did notice something when Defense+ was not installed.

When Defense+ was not installed I was able to kill off/restart the cmdAgent.exe and cpf.exe. Once cmdAgent was restarted, I was able to launch cpf.exe from the desktop shortcut and access all the settings. The tray icon also appeared. Upon reboot the same symptoms were back.

What you describe I have heard before. I am not sure if they had a cause or solution to the problem. Is your system a 64 bit processor by chance ? I seem to remember that the iTanium (?) processors did not work with the current release.

No, I made sure to include that in my topic that it’s x86.

Sorry that I am not being much help. Please try posting this as a bug report. That should get a more useful response.

You’ve been of great help! Suggestions and questions can often reveal things that others may look over. Plus you’ve been more helpful that even their support staff (ticket wise) has been.

Didn’t have the rest of your problems, but that exact problem happened to me. I have never seen a program installer ignore such a basic contig instruction before.

I agree. If you do not want Defense+, why still forcefully install the Defense+ Kernel? Let a person later modify their install if they want it, so it can be easily added as a majority of installers allow you to do.

Try uninstalling CFP (again) and then check to see that the CFP directory is erased. C:\Program Files\Comodo\Firewall should be gone. If not, delete it. Then make a Restore Point using System Restore (should be on your Start>Programs menu, but if that is hard to find the exe is %SystemRoot%\system32\restore\rstrui.exe). Then click Start>Run> and type regedit and press Enter. On Regedit’s Edit menu, click Find. In the find field, type Comodo and locate the keys relating to Comodo products. If you have other Comodo products installed, you will have to be sure that you choose only those keys relating to the firewall. As you locate entries that are CFP entries, remove them. There should be no entries left to find, but uninstallers sometimes forget some entries. After finishing that, turn off any security software that you have on your system. Once that is done, reboot and try installing CFP once more.

Uninstalled 2.4, cleaned out the registry again, rebooted. Recleaned the registry and rebooted once more. Then installed Comodo with just the firewall and the same issue occurred.

Well, unprintable!!! Can’t say we didn’t try. Any tray managers/startup managers or the like? At about this point, I would think that a bug report is justified. Maybe a screenshot of your TaskManager Processes tab with the bug report would help them figure it out.

Nope, I run a vanilla Windows. I’ve never used nor will I ever use any of that nLite/vLite ■■■■ that maliciously alters your Windows installs by ripping out services and other functions that are part of Windows. Only two things start up with my computer (aside from services) and that’s a keyboard program that allows for the extra multimedia keys on my 104 en-US keyboard to function and a program that communicates with my printer. None of which are interfering according to the crash dumps that I’ve analyzed.

v3.14 special beta has the same issues.

Sorry to hear it. Have you sent in a big report? I am not an official Comodo rep, so I don’t have their ear directly.

I’m not bothering to send in a report on this issue. The last issue I sent in a report about has been ignored for over two months now.