problem with WMP "play to" function


When using Windows Media Player to stream media (using the “play to” function) to my WD Live TV (media player) or Smart TV it takes very log to connect and I get a failure to read file notice. When disabling the firewall in CIS everything works as it should and I am able to stream the different media files.

My setup:

Desktop with windows 8.1 OS, wired to home network
Comodo CIS: product version 7.0.317799.4142
Sony Smart TY, WIFI connected to home network
WD Live TV media player, wired to home network

When using a laptop (OS Windows 8.1 and same CIS version) in the same network I have the same problems as described above.

When running a laptop (OS windows 7 and same CIS version) I have absolute no problems, it looks like a problem created by the combination windows 8.1 and the firewall in CIS.

Please your feedback how to solve this problem, I have been using CIS for many year and are very satisfied with this product, I would be a shame if I had to change.


Can anybody help with this subject?



I seem to be having a very similar problem with WMP play to on my windows 8.1 laptop not working when comodo firewall is active if I turn it of it work fine any help would be appreciated.

Lenovo g500 windows 8.1 connected by wi-fi
Lg 42lm620t connected by ethernet
Comodo CIS 7.0.317799.4142

Thank you

Don’t worry fixed it by uninstalling comodo completely and using a different firewall and antivirus software for now.
I don’t think comodo works to well with Windows 8.1 everything now works with Windows the play to and Xbox live now work if they ever fix this I’ll try again.
And yes I did try a clean install of both Windows and comodo still didn’t work and my friend who’s a network engineer for Kingston communication ( Google them) couldn’t get it to work properly in widows 8.1 for me, so what chance did I have.
Hopefully back soon if they fix this.


This has been an ongoing problem with Comodo that still needs to be addressed. Does anyone have a solution?

I have the same issue with the CIS and WMP combination; I managed to fix it by running a small script everytime before I use the Play-to function, this is the script: (run this .bat-script as admin)

-----------------------------Bat script-------------------------------------
net stop “Windows Media Player Network Sharing Service”
net stop “UPnP Device Host”
net start “UPnP Device Host”
net start “Windows Media Player Network Sharing Service”



Can anybody help with this subject? Comodo Hero? Settings Firewall?