Problem with WarCraft III [Resolved]

I’ve got a problem since I have COMODO Firewall Pro with a Game.
It’s WarCraft III and I can connect to the WarCraft III server but I can’t host games or invite to play to friends. I’ve tried giving all permissions to the game but I’ve not got anything.
I give permission to the Application selection this and “Skip parent check” and selecting “Allow all activities for this application” and “Allow invisible connection attempts”, “Skip advanced security checks” but it’s the same… I’m not able to play. Some advice?

I ve tried to put this rule:

Application: war3.exe
Parent application: Fronze Throne
Action: Allow 
Protocol :  UDP
Direction: In/Out
Destination IP : any
Destination Port:
 Single Port 6112
Allow invisiable connection attempts.

But it’s didn’t work :frowning:
Thanks so much.

PD: I’m spanish, sorry for my english

Check here:

Thanks but I have seen it. I’ve taken the above rule from this section.

Since your trying to host games, you probably need an INbound rule somewhere in NM.
Checking the site:

  1. Make sure you have the latest updates installed from your Firewall manufacturer
  2. By default Warcraft III uses port 6112, use the following steps to check the current port your version of Warcraft III is trying to use
    1. Start Warcraft III
    2. Click Options
    3. Click Gameplay
    4. Approximately half way down the screen you will see Game Port, this is the port you will need to make sure your Firewall is not blocking incoming or outgoing
  3. Try playing the game
What ports are required and with what settings? In order to connect to, through your Local Area Network, while allowing others to connect to games you create, make sure you have the following ports setup as described below. (...) Warcraft III:
* Allow port 6112 TCP out and allow established sessions in
* Allow port 6112 TCP in (hosting custom games)
* Allow port 6113-6119 TCP out and in (hosting custom games if you’ve changed the default port in the Options/Gameplay screen)</blockquote>

So i gather you need a rule for TCP protocol, IN, destination port 6112. Move this rule above the last “block all” rule. The rest is taken with Comodo’s default NM rules.

NM= Network Monitor

Don’t forget to report back!

Thanks. Sorry, but I’m slow with this things… So I must create the followin Rule:

On the “Applicacion Monitor” I Add a rule.
On Application / Father Application I put “war3.exe”
I select “Ignore Father verification”
GENERAL => Action: Allow | Protocol: TCP | Direction: IN
Destiny IP => Any
Destiny PORT => Only one port: 6112

Move this rule above the last "block all" rule
I don't know where this "Block all" rule is. ???

With my above configuration I have tried to host games with WarCraft III but… I can’t :frowning:

Sorry again :frowning:

I’m fairly sure he means the safety net rule (see attach), in network monitor. I think for direction you have to set it at in/out though:

* Allow port 6112 [b]TCP out[/b] and allow established sessions [b]in[/b] * Allow port 6112 TCP [b]in[/b] (hosting custom games)

You might be able to get away with making that App rule, but set the direction on in/out and see what happens.

[attachment deleted by admin]

The rule is for the Network Monitor. It only needs an IN rule since OUT is covered by Comodo’s default rules.

Go to Network Monitor, click Add - then select Allow; TCP; IN; destination port 6112.
Then move the rule up, so it is above the last rule. (select the rule, and use the up arrow to move it).

If you have doubts, post a screenshot of where you got stuck.

:BNC (:CLP)Wow Thanks so much guys!! I have solved the problem without problems now. Thanks so much. Cheers! :■■■■


Great, glad to hear you’ve gotten it worked out. We’ll mark the thread as Resolved and close it. If you need it reopened, simply PM a Moderator (please include a link to this topic) and we’ll be glad to do so.