problem with virtualbox network

My box is windows 7 x64 and installed virtualbox 4.1.10. And I have a Centos vm and at centos I installed dyndns.org.

The Centos vm has two dyndns.org address and it has a web pages.

After installing CIS, I could not browse these pages.

I added virtualbox to trusted files. But still can’t open Centos’ web pages.

The host ip is 192.168.0.2, and Vm’s ip is 192.168.0.4, but there is not vm’s ip at cis firewall.

Any helpful comment would be appreciated.

Thanks in advance.

Additional information about this problem.

The attached jpg file is firewall settings.

I want to open this mac address in and out, and get ip address at linux guest.

[attachment deleted by admin]

To allow for both incoming and outgoing traffic to a network you need to make two Global Rules; one for incoming and one for outgoing traffic.

If you want to also share files and folders you could use the Stealth Ports Wizard, option “Define a new trusted network and make my ports stealth for everyone else”. Then CIS will adapt Global Rules, and the according rule for System in Application Rules (System handles file, folder and printer sharing).

EricJH/ Thanks for your reply.

Is there some guide documents for setting Global Rules - in and out going?

I made Network Zone and add Global rules as attached pictures, but the ping to gateway failed.

[root@localhost ~]# ping 192.168.0.1 PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data. From 192.168.0.4 icmp_seq=2 Destination Host Unreachable From 192.168.0.4 icmp_seq=3 Destination Host Unreachable From 192.168.0.4 icmp_seq=4 Destination Host Unreachable ^C --- 192.168.0.1 ping statistics --- 6 packets transmitted, 0 received, +3 errors, 100% packet loss, time 5771ms pipe 3

[attachment deleted by admin]

What did you fill in for Destination Address in the Outgoing rule and what for Source Address in the Incoming rule?

EricJH / I made “test” zone with 192.168.0.4’s mac address at network zone. And input this “test” zone.

[attachment deleted by admin]

Do I understand correctly that CIS is on the host? Then you need to reverse source and destination in both the IN rule and Out rule.

EricJH/

Yes, I intstalled CIS on host windows.

And I re-installed host windows, guest linux, virtualbox, and CIS. then CIS’s network zone automatically made “work #1” by itself.

So I added 192.168.0.5 as shown at attached pictures.

And let me ask a question. If I have several dyndns addresses at guest linux, then should I add them to “Work #1” at network zone for communicating with outside of windows and linux?

This is the result of ping to linux’s dynsdns address.

[root@maestro krusader-2.0.0]# ping myserver.dyndns.org PING myserver.dyndns.org (xxx.xxx.xx.xxx) 56(84) bytes of data. ^C --- myserver.dyndns.org ping statistics --- 9 packets transmitted, 0 received, 100% packet loss, time 8788ms

[attachment deleted by admin]

I forgot the DMZ setting of the internet sharing router.

it works perfect!