Problem with Utorrent after the last 2 updates [Resolved]

I’ve been using comodo 3 since it was released but after installing 3.0.19 I’ve had problems with utorrent. all torrents show up red with “no connection could be made because the target machine actively refused it”. The starnge thing is that I have a Green tick at the bottom to say that is is configured correctly.

My rules are as follows:

  1. allow ip in from ip any to ip any where protocol is any
    2 allow TCP or UDP in from ip any to [static ip address] where source port is any and destination port is [forwarded port]
  2. block ip out from ip any to ip any where protocol is any.

I admit that I’m a total noob when it comes to firewalls. I got these rules from this forum somewhere and have often questioned the first rule but don’t know enough about it.

Anyway the only way i can get the torrents to download/ seed is to disable the firewall. The above rules have worked for me since I first set them up on Comodo 3, it is only the past two updates that has broken anything.

Can anyone give me any suggestions? I can provide more information if needed. it’s something i want to get sorted out as soon as I can, I don’t like running without a firewall.

Thanks in Advance

Si

As an addon to this, Soulseek is having the same problems. The rules are the same as set for utorrent with the port changed to the one forwarded for soulseek.

the way I update comodo is to download the full file and run it, it uninstalls the previous version and then after reboot i run it again to install it, it’s a bit of a hassle to put all the rules in again but i prefer to install a fresh version rather than update. Would it help if I ran the comodo leftovers removal batch file from this forum? and then install a fresh copy?

It seems to be p2p apps that are having problems as the rest of my programs are all ok.

Greetings!

It looks like your lacking a rule that allows outgoing TCP and UDP. Try creating one. You should also remove the first rule that allows all incoming traffic.
Rules should be something like this:
Allow TCP/UDP In From IP Any To IP [static IP-adress] Where Source Port Is Any And Destinaton Port Is [forwared port]

Allow TCP/UDP Out From IP [static IP-adress] To IP Any Where Source Port Is Any And Destination Port Is Any

Then add a rule that’ll block incoming and/or outgoing IP.

Cheers,
Ragwing

Thanks for the reply Ragwing, would it be better to create two rules (in and out) or just have one in/ out for the TCP or UDP?

I’ve now got the following rules

allow TCP or UDP in/ out from ip any to [static ip address] where source port is any and destination port is [forwarded port]
block ip in/ out from ip any to ip any where protocol is any

I haven’t had chance to test them yet I’m downloading sp1 for Vista so want to keep other bandwidth to a minimum until that finishes.

Thanks

That rule wouldn’t work, as it would only allow outgoing on your forwarded port. The forwarded port is used for incoming connections only. Outgoing connections use other ports than that one, so you should allow outgoing TCP/UDP-traffic on all ports.
Also, it’s not possible to have your IP-adress as the destination for outgoing traffic.

Thanks a lot Ragwwing, got that sorted out once and for all.

I later realised why that rule wouldn’t work!!!

Great that your problem is solved!
I’ll go ahead and mark this topic as resolved. If you would encounter further problems, PM an online moderator with a link to this topic, so that he can open it for you.
Else, you can always PM me, or some other moderator :wink:

Cheers,
Ragwing