Problem with update or uninstall/fresh install

For the last 2 days I have tried to update or uninstall/fresh install CIS (firewall and defense+ only). Everything seems to be working OK with either until after the computer restarts. At that point my network is blocked and the Summary screen says there is a problem with the firewall. Running diagnostics and then trying to fix does not work and after a bit will tell you it was unable to fix. At that point nothing seems to correct the problem, except a system restore to a point just before I tried to update.

Windows Vista Ultimate SP1 32 bit
Comodo (not shown on “About”, pulled from cfp.exe and cmdagent.exe)
Also running:
AVG free antivirus/antispyware 8.5.329
WinPatrol free 16.0.2009.2

Even though I have liked CFP in the past, CIS has caused lots of problems during updates and that is just about to make me drop it and go to another firewall.

Please download the latest version of CIS 3.9: . It holds a lot of fixes for starters.

It is recommended not to use a configuration of 3.8 as there are some changes to the default policies. Uninstall 3.8 first and install of 3.9 after the reboot.

As the thread title and my post mentioned I have already tried uninstalling 3.8 and clean installing 3.9 numerous times. I have just tried 5 more times (thank god for system restore) with the same results everytime as I mentioned in my first post.

One problem I am seeing is that after uninstalling 3.8 (before installing 3.9) my network connection is blocked. The Windows Firewall is turned off, so that shouldn’t be the reason. I haven’t checked at that point, but could it be that the Comodo Network Drivers are not being uninstalled and thus new 3.9 network drivers being installed.

Right now I am at a conundrum in that I can not uninstall Comodo completely, I can not update 3.8, and I can not upgrade to the new version.

Any help with this would sure be appreciated.