Problem with the list of trusted applications

The music engraving software LilyPond wants to create a helper process. I attach a file, defense_alert_create_process.png , a screenshot of the Comodo Defense+ alert of Lilypond trying to create that helper process.

The current situation is that Comodo Defense+ is blocking an essential step in LilyPond’s proceeding, causing LilyPond to exit with an error. Currently LilyPond executes correctly only when Defense+ is disabled.

When I first ran Lilypond I was prompted by Defense+, whether to trust LilyPond. I was given two options: treat this program as ‘Windows system application’ or as ‘Isolated application’. Since Lilypond is not a Windows system application I opted for the type: ‘Isolated application’.

A possible way to proceed is to remove LilyPond from the list of trusted applications, so that Defense+ will prompt me again when LilyPond becomes active.

However, LilyPond is not present in the list with trusted application.
To verify that LilyPond is not present in the list of trusted applications I tried to add Lilypond to the list of trusted applications. Defense+ then informed me that LilyPond is on the list of trusted applications

I attach a file, comodo_already_safe.png , a screenshot that shows this self-contradiction.
Alphabetically LilyPond comes after Java, and before Microsoft. It’s not in the list, but the alert claimes that it is.

I don’t use the Sandbox capability. The CIS Sandbox is set to ‘disabled’, and it has always been set to disabled.
This recommendation:
Suggests that choosing ‘Isolated application’ will trigger Sandboxing. Will it also trigger sandboxing when the Sandbox is disabled?

I resolved the ‘list of trusted applications issue’. As part of testing things I had installed LilyPond in another location, without removing the original install in Program Files. I read in the documentation that CIS stores a hash of the actual .exe as an identifier. So when I tried to add the one in the directory C:\Program Files\LilyPond.… Defense+ reported that it that hash already.

The problem that remains is that I don’t know how to keep Defense+ from blocking LilyPond.

LilyPond itself isn’t blocked. LilyPond requires a helper process, and by the looks of it Defense+ is blocking the creation of that helper process.

Issue resolved completely now.
The location for removing Defense+ rules is ‘Computer Security Policy’. I removed the rule that I had created incorrectly, and then I removed LilyPond from the list of trusted applications so that Defense+ would prompt me again.
Lilypond started, and this time I made the correct choices in the alert boxes.

[attachment deleted by admin]