Problem with some websites


First I am very sorry if this was asked before, but I couldn’t find any advice.

I have this very weird problem which started about 16th of may. First I thought it was just that some pages went down and will come up in a while, but after a month of not getting up I finally got myself thinking that something is wrong… Especially when one of the sites is The other sites are and few other like kaspersky etc.

Weird thing is that when I reinstalled CIS then everything went back to normal just for about half an hour. Now I had to uninstall whole CIS to be able to write this topic on this forum.
The error that was coming up when I tried to enter any of these sites was “couldn’t find host”. And it wasn’t only Firefox or IE, I coulnd’t get updates for comodo antivirus and etc.
It is getting really frustrating cause I am using comodo for a very long time and never had any problems like this and now I can’t use it at all.

My computer is free of viruses and malware, spyware etc. so it’s not the problem.

The other weird thing is that my second computer (a laptop) has the same problem! At first I thought that it was my internet provider, but since I temporarily fixed it (after reinstalling/uninstalling CIS) I am sure that it is a problem with the firewall itself.

Is there any way to bypass it?

That seems truly odd. What version of CIS are you using on what OS?

Can you show us a screenshot of your Global Rules? They can be found under Firewall → Advanced → Network Security Policy → Global Rules.

Im running Windows XP and CIS 3.5.5 the newest one available for download.

Also I take everything back. It seems the sites stoped working after a while even without CIS running or even installed.

I really don’t know what to do, cause it seems that it just randomly happens.

[attachment deleted by admin]

Are you on something like a home network, behind a router running its own firewall / intrusion detection? I did have a problem once, where my router’s built in intrusion detection was occasionally blacklisting a website I was using to watch some streaming media. As a result I couldn’t get to that site for a few hours. Then it would start working again, then would get stopped, and so on. Try investigating your router’s firewall logs, perhaps.


Can you show us a screenshot of the firewall logs? They can be found under Firewall → Common Tasks → View Firewall Events.

"couldn't find host".

This sounds like a DNS error.

If you are still using CIS, please take a screen shot of your application rules. Also, are you using a ‘hosts’ file or any kind of IP blocker, peer guardian/protowall etc?

Sorry for no response, maybe you guessed it but I was blocked from this page since yesterday.

The problem was fixed with Winsockxpfix, I don’t really know what happened but probably something with the registry keys.

It had nothing to do with comodo firewall and I’m not using anything else.

I have a network with 2 different IPs through cable modem, only using a switch, without a router so it wasn’t the blacklisting.


Okay back to the drawing board… after 15 minutes the stopped working.

I used winsockxpfix again and after the reboot everything started to work again, but I’m not really sure for how long.

Yeah again blocked for 2 days. Anyone has any advice?

Seems like a very rare problem, cause i only found one person on some forum with a simillar problem (different sites blocked).

Now I used winsockxpfix again and it helped but its really temporary, like for 10-15 minutes.

May be malware is messing the socket. Please follow the What to do if you’re infected - eXPerience Rev.3 tutorial and see if that helps.

Keep us posted.


After a long battle I narrowed down the problem to one of the services using svchost.exe

As soon as I turn on DNS client I can’t access Microsoft pages etc. but if I turn it off everything is working fine. Also I noticed that I had many services turned off, problaby due to some old malware that I had many weeks ago. One of the services turned off was auto updates for example.

Also something ■■■■■■■ up my sound drivers and as soon as I played some game and after a while turned it off and wanted to watch a movie or do sotmehing including sound the sound wasn’t there. The drivers were in place but seemed to be missing physically. Anyway adding a line:


in the services.ini fixed the problem.

I scaned the computer with the programs you mentioned above, but didn’t find anything, but they seem to be very good programs so I’ll have a look at them next time I have a problem like this.

Hopefully my computer will stay clean for a while now and I won’t have freaky and interesting problems like these anymore.

Oh wait… I still have to do the same thing on my laptop, darn…

Thanks for all the suggestions, they were helpful in turning my eyes in the right direction. Please don’t close the thread, cause I still might be wrong and the computer might still playing tricks on me :P.