Problem with permissions (rights)

I have this sort of problem on an installation of XP SP3 on which I use Comodo FW (only) since a long time and at a moment appeared this problem :

often when I want to launch an installer setup I get a windows message saying that I have not the rights for that , though I am under an administrator account

and I must reboot windows to have this problem solved

This problem could be also caused by the security updates of windows ? or by the install of IE8 or by Comodo

The OS could need to be reinstalled, but I don’t believe it could be that the cause, because I restore the registry regularly at a previous point so that I consider this OS being really 1 week maximum old instead of his 2.5 years appearent

The bug/issue

  1. What you did: I double click on an executable file which is an installer setup
  2. What actually happened or you actually saw: this operation does not run the installer. Instead there is an error message pop-up saying that
  3. What you expected to happen or see: run the installer
  4. How you tried to fix it & what happened: reboot windows and it is a solution but heavy
  5. If its an application compatibility problem have you tried the application fixes?:
  6. Details (exact version) of any application involved with download link: googleearthsetup version for example but nearly all installer setups
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: yes it is possible at many times as I want if I re-do
  8. Any other information (eg your guess regarding the cause, with reasons): problems with proative defense of Comodo, though it is disabled

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: attached file
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: ///
  3. A CIS config report or file. : is it useful ?
  4. Crash or freeze dump file: ///

Your set-up

  1. Comodo Firewall 5.0.163652 no anti-virus
  2. I uninstall Comodo at each update of the application
  3. I imported a previous config version
  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. ) : none
  5. Defense+ and Sandbox OR Firewall security level: disabled, disabled, advanced level

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation



This is most likely due to a simple wrong setting - do you have auomatically detect installer/updaters ticked under Defense plus settings? If not please do

If it’s not that please try a clean install using this process here.

If neither work then you may have a bug. Please edit your first post to make sure you include all requested setting information.

Best wishes



Proactive Defense was disabled

but I watched the settings anf I set the choice “disactivate defense plus permanently”
and I disabled the “control of the execution of images” : ?

I will test these new settings

Any feedback? Did this work?

Please try a re-install using the process suggested a this may well resolve matters. You can back up your settings using ‘manage my configurations’ - but please don’t reimport until you have tried out the standard settings.

Best wishes


PM reminder sent

Unfortunately we do need all the information we have asked for, if we are to forward it to verified issues.

For the moment I am going to move it to the Orphaned/Resolved child board. If you do manage to edit your post add the information requested please pm us and we will move it back again.

The devs only look at the Orphaned/Resolved board if they have time, so please do edit the post and PM an active mod if you want it fixed.

Best wishes and many thanks in anticipation


Yes Finally it resolves the problem

In Defense + Settings, activate the “Deactivate defense+ permanently” item (and system restart) is enough
then save this new configuration


It resolves the problem but there is thoug an issue because this should not happen
Having chosen the installation without defense plus, shoud déactivate defense plus perfectly

Thanks for trying these settings.

If this happens after a clean install, after setting the d+ security slider to disabled, then I would consider it to be an issue, yes.

But you will need to try a clean install by the process recomended above without importing settings. Else it could be that you are importing corrupted settings.

Best wishes


I think I got a permanent problem of this kind after that, but far less ennoying.
The installer lauched, and only a part of them, not all, take much time to launch after the double click, as perhaps 3 minutes at the clock, an sometimes it is the same problem for some executable.

Then I let that in this state for 4 years dancing the salsa and other stuff ;D

I am with Comodo 5.10 and wish to continue with it, so I could try to test one of theses installers after desinstallation of Comodo but there is so many things to manage in a PC … that perhaps or not

Jerome, this topic is almost four years old. No need to kick an old topic back to life or to promote the gospel of using v5.10. You’re on the mod’s radar.