Problem with MS Virtual PC 2004/2007

I am having problem running MS Virtual PC with CAVS installed. I can only start up one session of VPC, second VPC will always get the message of not having enough physical memory (see attached), even though I have plenty to spare. In fact the problem would go away if I uninstall CAVS. However, that’s not the kind option I am hoping for. Can anybody advise?

My System

XP Pro Sp2 with all updates
CAVS beta
Comodo BOClean
Spyware Terminator
Pentium-D 2.8Ghz

Nope, I don’t have nero’s InCD installed…

[attachment deleted by admin]

Can you let us know exactly how much PHYSICAL RAM is free on your system when a single WindowsXP VPC session is running? This detail can be obtained from the PERFORMANCE tab in Task Manager. Just start your system up, start an XP VPC session and, before doing anything else (including loading any applications in the VPC session, as they consume RAM as well), grab these details from Task Manager.

On one of my systems (1 GB RAM) with just a browser and Task Manager running, I have 500720 KB free. Admittedly I have a reasonable amount of “stuff” running in the background, but nothing excessive or exorbitant. As such, I’d only be able to run one XP VPC session on this PC. The rule of thumb I’ve heard is to allow 384MB per XP VPC session, regardless of whatever MS say you need, and this amount will vary upwards if you run apps consistently in the session.

Hope this helps,
Ewen :slight_smile:

Hi panic,

I do believe that it has to be a bug in CAVS. I saw a similar thing when I was running ubuntu on a virutal box. I tried to download a small file (about 7 mb) on my windows host and the system reported that the disk was full even though the partition had 36 GB free space. ???
Another time I tried to open an exe on my host and I saw the exact same message of foxman. But I had more than 1gb of free physical ram. ???

Hey Pan,

I don’t doubt it’s a bug ;), I just wanted to confrim that there was sufficient physical RAM present, before getting him to lodge a support ticket.

Occams razor usually cuts the sharpest. :wink:

Ewen :slight_smile:

Oh yes, I have got about 520+ MB free RAM with all my things loaded. After starting anyone of the virtual machine I have setup (8MB (for DOS), 128MB (W2K) and 256MB (XP) RAM allocated respectively), the second one just won’t load anymore. The problem does go away after I uninstalled CAVS, in fact, I could load all 3 of them simultaneously, just noticably slower.

I finally have to resort to uninstalling CAVS, and reinstalling the old faithful Avast 4.7. Now everything worked like a charm! So confirmed it’s a problem with CAVS. Guess I will have to stay off it until next beta release or version… (:SAD)

Well, no one has any suggestion on how to resolve this?? (:NRD) Any indication of whether ill this problem will be addressed on the next update or next version? Hello?? (:AGY)

Sorry there haven’t been any other suggestions (or any suggestions, at all, I guess…). I think panic’s idea (as per his Reply #3) was for you to file a ticket with Support to see what thoughts they might have.


Oh, I just did. Thanks… sop at least someone noticed… (:SAD)

(:SAD) Sorry you’ve been all alone in a dark room, foxman.

Keep us posted on how Support responds. I don’t know that they’ll be able to help, but we can hope. In the meantime, hopefully a few more responses in the thread will increase your coverage and someone else will jump in as well… :wink: