Problem with Firefox logging into sites

Installed Comodo firewall 3.5.57173 and am having problems with Firefox logging into sites. Since i’ve installed COMODO firefox will not log into email sites/social networking sites such as yahoo, facebook, hotmail, etc.

I’ve defined the rules for firefox to be a web browser, trusted application, and it still will not connect. (tried it as a web browser and switched it to trusted application then back to web browser)

I have three other browsers on the computer (IEexplorer, Opera, Chrome) and they all log into the sites mentioned above without any problems (they are defined as web browsers)

help plz.

I’m running COMODO and firefox on vista.

Evening,

Please Check Firefox Settings
Under Privacy
Then “Accept” Cookies is checked

CG

Thanks for responding and for your help.

Firefox is set to ‘accept cookies until they expire’. I’ve also decided to uninstall firefox and do a clean install (with no plug-ins or add-ons) and it still doesn’t work. :\

Does it work with other browsers like IE or Opera?

I remember somewhere someone how a problem like this, and thought it was Java that CIS blocked.

  • Uninstall Java
  • Purge the D+ policy, then do the same for the Firewall policy
  • Download and install Java
  • If any alerts pop up about java.exe or some of it’s “friends”, allow and remember their actions
  • Restart your browser and try to log in again

Can you post any other security programs you have running?
What OS and Bit Are you using?

CG

I’m using the latest version of the free version of Comodo and have not experienced such problems. I’m no technical expert but I suspect your problem may be with Firefox rather than with Comodo.

Since you mention that you have other browsers out of all of them which is set as your default browser? Often I’ve noticed if I set Firefox as the default then when I install Opera it seems to adopt some Firefox’s configurations and one time I had it with IE being my default browser and Firefox had a few problems but it was fixed after I set Firefox as the default browser.

Do you have addons with Firefox? By any chance do you have NoScript enabled?

I’m running:
CIS
Vista 32bit
Spywareblaster
Spybot
Ad-aware
AVAST

I’ve noticed that when i close CIS the problem still persists (all other browsers will log into sites except firefox)

I’ve done a reinstall of firefox so that i have no add-ons, and it still does a perpetual loop where it refuses to log in. i believe my problem is with firefox and not CIS. Firefox is my default browser.

I was actually switching to Comodo from Webroot firewall. I tried reinstalling both firefox and comodo and it didn’t work so i did a system restore.

I have both firewalls (CIS and Webroot) on my computer, but only run 1 at a time. Strange thing, I have to open webroot, then close it, and firefox will log into sites - so it has something to do with webroot firewall.

[Solved]

I uninstalled the version of webroot that I had on the computer and everything is working fine. I had originally just disabled it from starting up in msconfig while i tested CIS but apparently that wasn’t enough. Now that I’ve removed webroot CIS seems to be working fine.

Thank you for your help!

Firewalls usually have more than one component running. So my suspicion is that a module Webroot firewall starts with Windows without you knowing.

Try Autoruns to disable all instances of Webroot Firewall from starting: Autoruns for Windows - Sysinternals | Microsoft Learn .

When I wanted to post there was a new post. Apparently you have uninstalled WF. Still I leave the reply as it may be useful.