Problem with "Enable alerts for UDP requests"

Unchecking “Enable alerts for UDP requests” disables my internet connection.
Logs show nothing blocked, any idea why? My apps rules and global rules.
Allowing all in global rules, with adding loopback rule for IE, did not help.

Windows Vista Home Premium x86 and Comodo Firewall Pro

Does it disable your internet connection entirely? Or is there a DNS issue? Can you open the Google page by giving IE it’s IP (

Yes. When I tried, I got this and then this.

Couple of suggestions:

  1. Go to the beta board and download/install the current 3.0.14 build. Export your settings first. When you have the new version, don’t import your settings yet. Uncheck "enable alerts for UDP requests so we can see whether it might be a conflict vs a ruleset issue.
  2. Import your current ruleset and select it. But put “block and log all” rules at the end of your application ruleset for ie, cmdagent, svchost so we can start looking for which program is not getting something it needs. Remove the “block all out” from your global rules.

What is your other security software? Virus scanner, etc.

Sorry, that I have not responded for so long, I am busy in work.

1, The same issue remains.
2, Nothing showed on logs.

But I have to apologize for providing bad info. I loose network connection, when I open new aplication, already running aplications, like new tabs in IE or WMP, work, but when I open a new process of IE or WMP, it does not work, so it might have something to do with Defense+. When I enable UDP alerts and click on refresh in IE or play in WMP, it starts working like nothing happened. BTW, I have DNS Client service disabled.

Have you tried it with DNS client service running? I can repeat your symptoms if I turn off DNS client service. Turning off services can interfere with many other programs, so check a source like and see that you aren’t going beyond “SAFE” in the table.

I see, well I guess, that I have to learn to live with UDP alerts on, because eg disabling DNS client service is safer and speeds up my internet connection a bit, especially with OpenDNS servers. Anyway, thanks for help. :wink:

There is no need to enable the DNS Client service, just create a rule or two to block and don’t log those entries you don’t want to see…

Yes, it can be done for allowed aplications, but not for new. I also wanted to disable it, because I am not the only one using this PC and someone could allow some trojan by an accident. 88)