Problem with Dragon and Windows 8


I have problem after todays Dragon update. Please look at on flash in the attachment. I have this problem on 3 PCs with W8 64b.

Is there any solutions?

Sorry for me English.

[attachment deleted by admin]

Can you please explain the issue you are having? I cannot open your attachment.

Please unzip attachment and run in any browser or another program. Attachment is in .swf format.

Can you please translate that warning you get into English?

I will try it but I don´t know if it will be exact as I don´t speak well IT english so I don´t know if I translate it well.

It is probably something as CLASS IS NOT REGISTERED.

I’ve seen a few other people getting exactly the same error message, but while doing different actions, with the new version. Hopefully someone will figure out a workaround.

However, until that happens it would be very helpful if you could put this bug report in the format described in this post.


I have been getting the same error message on windows 8 trying to launch CD from the task bar, if i unpin the icon then repin it from the start menu, it will work one time, then i get the message again.

I would like to add i have both windows 7 and windows 8 machines, and it is only on the windows 8 machine, the icon in the start menu works fine launching every time, as well as the icon in the widget for sandboxing, it will launch no problem, it is only the task bar icon i keep getting the error with. Hope this helps narrow it down…

I just wrote something really simple in C++, it could be written as a .bat file however I have been unable to pin a .bat file to the taskbar so that prove useless.

#include <Windows.h>

using namespace std;

int main()
system("start dragon.exe");
system("taskkill /F /IM Project1.exe"); //Replace Project1.exe with the name of the soon to be compiled program.

Anyone who knows C++ and gets this problem, please try compiling that (or make your own) and then put it in the direction you installed dragon to, then pin the newly created .exe to the taskbar and do please test if it fixes it for you, it seems to have fixed it for me but I don’t know if it will stop working again with time.

As you see I’m a real noob with C++ and I’ve only read the basic of basics and don’t know how to execute a program through “normal” code so I just made it go through the system, basically just calling cmd commands.
Sadly I don’t know how to add an icon ^-^‘’

Reason it’s not given as a pre-compiled .exe - I don’t know if it fixes the problem so testing is needed first, also trust (I wouldn’t want to run something I didn’t know the code of)

Edit: Just noticed that the .exe file doesn’t close after launching Dragon so you have to close it manually, or if you know a way to kill it by code then you can add it to the .exe.

Edit 2: It seems to close after dragon closes.

Edit 3: Fixed the code to also close the .exe.

Edit 4: Removed the “fix” since it didn’t really work… <_<

Edit 5: Added another fix that seems to be working.

I am afraid to compiling code. Older version of Comodo worked with no problem.

Of course this isn’t supposed to be a fix of any sorts, just a little work around if you as me always use the Taskbar to start Chrome.

The code is very basic as you can see and I’m fairly certain someone that doesn’t understand C++ can still see what is done :wink: I’d still recommend only people who know what they are doing try this.

But so far I have not gotten that error message any more which is telling me that it is working as a temporary workaround, I have another idea with .bat files and will come back with the results of that since it wouldn’t need any compiling!

Edit: My idea with .bat file failed =/ Basically, Windows doesn’t allow the pinning of .bat files to the Taskbar, so I got the idea of making a shortcut to the .bat file however that doesn’t pin either. <_< Seems like Microsoft is serious about no .bat files on the taskbar!

Yes I understand. I do not want to mess in C+ because of the next Windows updates. I understand this is easy but I do not want to controll it with next versions/updates Win or C+.

It is strange when I right click on Dragon icon on the panel and then on NEW WINDOW, Dragon opens with no problem.

Btw, what do you mean by the part I put in bold? Are there any special updates coming that will change something in particular?

Then we have another work around!

Understandable. Btw, what do you mean by the part I put in bold? Are there any special updates coming that will change something in particular?
I probably cannot express myself in English. I mean when there is a newer version of C+, it will rewrite me my modifications. Maybe it does not work like that it was just an idea. I take it according for example to Joomla. When I do core modifications, next update of new version rewrites everything.
Then we have another work around!

Please have a look at the attachment

[attachment deleted by admin]

Hmm? I don’t quite understand what you mean, you just need to compile the code I provided with a compiler into it’s own program, after that put the .exe file in the direction you installed Comodo Dragon and after that Windows updates won’t really touch the program.
You’re basically just making a program that will launch another program, in this case Comodo Dragon.

Yes I understood that and it seems to be working here too.

In my case (CD, Windows 8 PRO x64, CD shortcut in Taskbar) of error “Class not registered” was helpful remove string “DelegateExecute” from the following registry keys:


Hope this may help you.

the fix Abyr posted worked for me. I had to delete all 3 registry items for it to launch from task bar. thanks abyr

Glad to help you and special thanks to the guys from, who have posted a similar solution about a year ago.

Thank you too, the changes in the registry worked for me. I did a restart uf windows and it still works.
I marked the CD as standard browser again (which i had to change because other programs could not open CD ) .
Now the bug seems to be gone.

This is only a partial fix. Any app which will need to launch the browser will complain about a missing default browser.
There is something very wrong with this version 25 as even a total re-install doesn’t fix the problem.

Overall I agree with you concerning CD Release.

Please note that above mentioned registry entries (DelegateExecute) return back after you set CD as default browser.

So delete them (DelegateExecute) once again.