Problem with downloads [solved]

Edit 15.08.12 : bug solved with Dragon version 21.0, at least for me.

I downloaded the new version of VirtualBox, but the file was save as".crdownload" instead of win.exe. This never happened with versions of Dragon previous to 20.0. I tried several time with the same result. Finally I made the download with Opera without problem.

If I’m not mistaken .crdownload files are for incomplete downloads.

Do others encounter the same problem with downloads in Dragon?


Specific symptoms of the bug and steps you can take to reproduce it : since Dragon version 20.0, each time I dowload an installer it is saved as a .crdownload file instead of a win.exe one.
Specific steps you have taken to try to resolve it : tried in incognito mode, disabled AV, restore system image prior to version 20.0 and upgrade again to 20.0
Comodo Dragon Version (Stable/Beta) : Dragon 20.0 (Stable)
Plugins/Themes installed in Comodo Dragon : Plugins : Remoting Viewer, Adobe Acrobat, Microsoft DRM, Windows Media Player, Picasa, Java, Flash 11.3.300.262. NB : all plugins are disabled.
Theme : default one
Extensions : Adblock Plus (beta) 1.2, Comodo Site Inspector 0.1, NotScript for Chrome OS
Windows version (w/ 32 or 64-bit) :Windows XP SP 3 (32-bit)
UAC status (diabled/enabled) if it applies to you [ for Vista/Windows 7 only! ]
System Drive where Windows is installed : C:
Place (installation path) where Comodo Dragon is installed : C:\Program Files\Comodo\Dragon
User privileges (administrator, limited user, guest, etc.) : administrator
If you have Google Chrome installed then please mention it’s version and weather the same issue reproduces with it. : not installed

NB : The problem doesn’t show up on my other machine running win7 with Dragon same setup and extensions as on Win XP

Hi Boris 3,
I haven’t encountered this problem, but yes incomplete, corrupt or unfinished download is correct.

If this happens again clear your browsing data including download history and also remove the incomplete file from the downloads folder before trying again.

Hi captainsticks

When the problem arose, I did what you mentioned, relaunched Dragon between each try but to no avail. I then thought that the installer I was downloading was corrupt and tried with Opera to check, but the file was downloaded without problem.

To be more specific, the installer I was downloading was VirtulBox 4.1.18 for Windows hosts.

Hi Boris 3
To me it sounds as if something/connection between you and the download location could be breaking in Dragon for some reason.
This could be a one off location error.
Only if this continues for other downloads or re-appears while downloading from anywhere else please consider updating the information following the instructions here and I will then move it to the Bug reports section.

Thank you.


I just made a test with:

  • Picasa 3.9 and instead of saving Picasa39-setup.exe Dragon saved “unconfirmed 29974.crdownload”
  • Dragon 20.0 and instead of DragonSetup.exe, I got “unconfirmed 24255.crdownload” (I downloaded from the forum)

I never had this problem before version 20.0 and my settings are the same than in the previous version.


Hi Boris 3,
If it is no trouble could you please try the same downloads in incognito mode and if this solves the problem it could be an interfering/conflicting extension.
If it worked try disabling all extensions in normal mode, enabling one at a time trying to download after each one.
Thanks for your time.
Edit: I hope you don’t have a low monthly Data usage limit.

Hi captainstick,

I forgot to mention when I opened the topic, that the machine on which I was downloading was running XP SP3.
I just tried on another machine running win7 and the problem doesn’t show up.

But with XP SP3, the problem remains. I’ve tried in incognito mode still got crdownload file. As the only difference between the machine running win7 and the win XP SP3 one is the antivirus - Cav in win7, Avast in win XP- (Dragon settings are the same on both machines) I tried the download with Avast disabled, that didn’t solve the problem either.


Hi Boris 3,
I cannot reproduce this issue and sorry a solution is evading us.

If you have the time, please use the modify function and add as much of this information as you can to the bottom of your opening post.
I realise a lot of this information is already posted, but by condensing it into the opening post it might assist the Developers.
I will then move this to the Bug reports in the hope that the Developers can reproduce the issue and find a solution.
Your time is greatly appreciated, thank you.

Hi captainsticks,

I filled the bug report in the first post of the topic.

Thanks for your help.


Thanks Boris 3, your time and effort is appreciated. :-TU
Let us hope it is worthwhile, topic now moved to the Bug Reports section.

I faced this prob today. I downloaded & saved few files on desktop, some files downloaded successfully & some were crdownload.

What I observed that when I checked the download section it mentioned insufficient permission for the files that were crdownload & I also observed that these files were actually completely downloaded but I guess coz of the insufficient permission they were showing as crdownload, dont know what is insufficient permission. When I renamed the files i.e if the file was .exe I renamed the crdownload to .exe & the downloaded files were working, digital signatures were fine & files were working. So the files are downloaded completely but due to that insufficient permission prob they were shown as crdownload.
But the prob is not with every downloads, some downloads are fine & some with this prob.

And when I tried to downlaod & save those crdownload files again to other locations they downloaded & saved fine.

So some prob saving on desktop but other locations like My Documents, C Drive, etc fine.

XP SP3 32 Bits

Similar scenario…

Downloading from Microsoft Download Center 4 sizable files (excess of 500MB each). 2 .iso files download properly, 2 .exe files show complete, but do not rename to the proper file names and show “Insufficient Permissions” in the browser download bar. When reviewed in the Downloads folder (dragon://downloads/), the 2 files show “Cannot save due to insufficient permissions. Please save to another location.” I have full permission to this folder, and the other 2 .iso files were saved successfully to this same folder. I confirmed that it is not a space issue as well (458GB free on a 1TB HD). The drive is also a secondary drive where I download all files before moving them to production.

I am running Win XP Pro SP3 32-bit, Comodo Dragon, with Comodo Internet Security 5.10.228257.2253.

Devs plzz reply here.

Strange 32 bits browser working flawlessly on 64 bits system but giving probs on 32 bits system.