Problem with Defense+ and exe files (3.8.64263.468)

Unfortunately, but you did nothing with the concerning problem “D+”. I have still (and not only me) problem with using exe files.

Files which, I have a problem with it for example: OpenOffice, Firefox, Thunderbird, Spamihilator, Skype, Keepass, RssBandit, SpeedFan, Celestia, MS Flight Simulator X, WorldWind, Driver: PL, Amaya, Opera and many many more.

I don’t have a problem only with Eraser, Comodo Registry Cleaner (interesting why?) and… Paint.

Runs only 48 processes with 68 ( I needs of these processes).

I had to deactivate D+ to work normally on a computer.

I added manually these programs to Computer Security Policy but this don’t work.

I am adding the photo. Red dots - programs with problems, green dots - programs which working with D+.

Why isn’t D+ asking about this programs (all security levels of D+)?

[attachment deleted by admin]

Could you elaborate on problems what exe files? What problems are you experiencing?

In practice all exe files. It affects games, browsers and other applications. For example: I have a file colors.odt but I can not open it, because is blocked by Defense +. There is no alert from the Defense+.

Or I am clicking on Mozilla Firefox.lnk (or exe) but the program isn’t being started. The firefox.exe process is starting at the Task Manager to the moment of second and this process is disappear.

Can you try this one??

Delete those applications with ‘red shots’ (those which are not working) from ‘Computer Security Policy’ of Defense+.

Change CIS to training mode (Right Click CIS>Defense+ Security Level>Training mode)

Run the applications one by one.

Once these are run… change it back to ‘Safe Mode’ or ‘Clean PC Mode’

Did it help???

P.S. (In order to check the functionality… instead of deleting all … you can delete only one application rule and check whether it solves the purpose or not).

[at]layman: I tried this on all levels and nothing but I will try one more time. I must inactive D+ because disable don’t help.

And strange thing: D+ asking (Paranoid Mode) about winamp and Windows Media Player… but isn’t starting them.

Important programs which have a problem with D+:
WorldWide Telescope
Microsoft Flight Simulator X
Driver: Parallel Lines
Mozilla Firefox
Mozilla Thunderbird
World Wind 1.4
Half-Life 2
Secunia PSI
and other

no problem with D+
Comodo Registry Cleaner

D+ asking but isn’t starting (only Paranoid Mode but only one time (after second delete in “Computer Security Policy” of D+, don’t asked me what to do):
Google Earth
HEXelon Max 6

Now, I noticed a certain regularity: All processes are 32-bit (I have vista 64-bit in the Polish language version).

Well, I don’t have idea.

Red dots - this processes have a problem with D+.

[attachment deleted by admin]

Why are you using ‘Paranoid Mode’??? It is highly proactive without much rights to the applications… Safe Mode or Clean PC Mode is much better… Paranoid Mode is for high skilled computer geeks who likes control on each and every move… which could be troublesome!

For an average user the better one is Defense+ in Safe Mode or Clean PC Mode and Configuration ‘Internet Security’ (if more control is required, then ‘Proactive Security’)… But, IMHO Internet Security with Safe Mode will sufficiently protect the computer as it will alert against any bad behaviour by new applications like viruses. All your ‘critical’ applications like winlogon are by default protected by CIS… so these high security features need to be explored when suspected behaviour is observed in your computer… These are my personal opinion…

You said you have 64 bit Vista in Polish language… I don’t know whether it has anything to do with your problems… I hope someone with this configuration or aware of it may report for this…

I can also request you to check something… Though you may be already aware of it… Open Computer Security Policy and double click on the application name… click on ‘access rights’ There are some buttons called ‘modify’… Double click on ‘modify’ and see there is anything in ‘blocked applications’.

I am telling this because some programs use hooks to carry out its functions, when a pop up comes, normally, we, as users just click block (and remember) it… then we forgets… Just see if your problems has something to do with that… In case there is anything ‘blocked’ there, unblock it and try in ‘training mode’.

There are many experienced players like Eric, Panic, eXPerience, Ronny etc. in this forum and if still the problem persists, I am sure somebody of them will come up another solution…

I always use the Paranoid Mode levels (from CIS 3.5) because I like to have programs and processes under control.
Checked at all levels:
Disable - blocked applications;
Training Mode - blocked applications;
Clean PC Mode - blocked applications;
Safe Mode - blocked applications;
Paranoid Mode - blocked applications.

Inactive D+ - programs and processes working but D+ is deactivate :frowning: .

I checked in “Access Rights” but I don’t have anything in the “Blocked Applications”. I have program’s path only in “Run an executable” as "Allowed Applications (for example: C:\Program Files (x86)\Mozilla Firefox\firefox.exe in Allowed Applications). Other options are clean.

If it was easy to solve it I did.

Really, I don’t any idea for this.

[attachment deleted by admin]

You mention that you’ve checked the blocked .exe’s at all levels, but you don’t mention if you’ve deleted the existing rule in CIS prior to attempting to run the application in training mode as Layman has suggested.

Yes, I did but no effect. I don’t know why but D+ isn’t learning in the “Training Mode”. I know that it should be working and it was in the CIS 3.5 version, but no in CIS 3.8.
If it was so easy I wouldn’t ask you for the help.

Sorry to ask this (stupid) question… Have you ensured that you installed 64 bit version of CIS 3.8?

It could be troublesome… but… please download a fresh copy of CIS 3.8 (64 bit) from the forum and do a clean install (without any import of configurations). You can also use revo uninstaller to ensure that nothing of the current installation remains in the computer… (It is my sincere wish that I am able to help you with the current installation. But, I am suggesting this as my current stock of ‘helps’ are not working in your case).

BTW you have mentioned that these problems are for 32 bit programs… Do 32 bit programs work properly in 64 bit windows? … are they working properly when defense+ is disabled or uninstalled?

(I have 32 bit XP… which works perfectly with defense+ … so don’t know whether there is any conflicts in 64 bit CIS 3.8)

If the problem still persists… please do report it here

So, I have checked twice what version of the file I have. And downloaded too.

I still have one idea. I had the same problem when I tested the beta version of the program. But I cleaned registry before the installation of the stable version.

Well, I will try again.

Thanks for all.

same issue had to remove ad-aware and do a clean install of cis. If your running Ad-Aware ( or maybe a similar program if your not running it)

Many people with same issue on CIS and Vista64 and most were solved by removing Ad-Aware

It’s working, thanks.

Wow… nice to know that.