Problem with CSC 2.0.11195.7


My OS: Windows Vista Home Premium SP2 (64 Bit) (fully updated)
Security Software: CIS 3.12.111745.560 (fully updated) / CSC 2.0.11195.7 (fully updated)
Intel i7-920; 6GB RAM, 2 X 1TB drives (RAID1 config)

Yesterday I ran CSC. I clicked on the “Clean My Computer” button (the “Single-Click” button) to run the registry/disc/Privacy cleaners. Since then my computer seems to continuously write to disc. As a consequence, everything else is slowed down to the point of being very annoying. Outlook 2007, for example, takes four to five minutes to start up and other applications take similar times. The red LED on my computer, which indicates a write operation, stays on continuously and has done so for the past 24 hours.

When I open Task Manager, I find that, under the “Processes” tab, the “Services and Controller App” takes up 1.6GB of RAM, even though CPU load is at 0. This is an improvement as yesterday the memory load was at 83%, which did not allow me to do anything on the computer.

Any help or suggestions will be most welcome as I’m falling behind with my work.

Thanks in advance.

Hi laneseda

Can you restore the files and reg. entries from Registry clean backup, Disk cleaner backup and Privacy cleaner backup. Then reboot and see if the problem still exists.

There was some problems with earlier versions and services.exe but with the latest version that was fixed.


Hello John,

Thank you for the quick response. I must confess I wrote that last post while I was very upset at not being able to use my computer. Moreover, when I tried to use Comodo’s LivePCSupport I received a message informing me that the server was down and to try again later. Hence the irritation.

I was not able to use the computer to do much as I kept getting that “system memory low” message, so I thought I’d let it run overnight to see if that made any difference. Well, it did and I was able to post my first message here. I should have checked the previous posts for more information. The problem is, I am a PhD candidate in theology - and have precious little knowledge of computing. I install software and expect it to perform as promised. Please understand, this is not to imply that Comodo makes false promises; far from it. However, as an end-user, I view my computer as a tool - a means to an end and not an end in itself. I do not play games on it, nor do I use it for any purpose other than to access material relevant to my academic interest. Oh yes, I also use it to read the news online - the Washington Post, NY Times, CS Monitor, Reuters, BBC, etc.

Okay, back to the issue at hand: I restored the file and registry entries and rebooted the system. It ran well for a while but today gave me the same “low memory” message. At the time of writing the Services and Controller App still takes up to 1.8 GB RAM (out of 6, which are in a tri-channel mode/format/configuration on an ASUS P6T Deluxe V2 motherboard) though CPU usage is at 1% and below.

I’ll wait for an update to the software, install and run it and see if that makes any difference.

In the meanwhile, please accept my thanks, once again, for your prompt and courteous reply. It is greatly appreciated.



We are very sorry that you encountered this problem. We are aware that although the problem was indeed fixed on most computers, on other systems the problem still appears. Our development team is working very hard on this matter and we will get back to you with a solution ASAP.

Thank you for your support.


Thank you for your solicitude; it is heartening to observe. I look forward to being able to download the updated software.

Kind regards,

Lane, Have you tried clicking check for updates in the bottom left of the CSC window? If it says you are up-to-date you may want to consider uninstalling CSC just for the time being until the next update is released. I suffered the same problem is you and I feel your pain. It was very, very frustrating to keep getting the memory low message on a machine with 2 gigs of ram!

Hello theantagonizer,

Thank you for your post. I did as you suggested and checked for an update. When I found there was none to be had, I uninstalled CSC and re-booted the computer.

This seems to have sorted the problem out. On checking I see the Services and Controller App has returned to a more acceptable 5MB of RAM, with total RAM used being around the 18% to 21% mark. More importantly, (at least to me), I’m now able to catch up on a bit of work.

Thank you for helping me out. I appreciate it very much! I’ll wait for the new version of CSC to come out.

Kind regards,

PS I like your nickname. Does this stem from playing the Devil’s advocate often? :slight_smile:

i reinstalled my system because of this problem and i read that it has been fixed in the latest release, so i tried that. but after cleaning and a reboot my ram was starting to increase again till there is no memory left to be filled and then it starts reducing it again…
i removed CSC and the problem is gone.

if you need any information on my system to figure this out, let me know. i also posted some infos in the bug report…

I do sometimes but only so that I can better understand. >:-D