problem with comodo and internet

I was pointed to Comodo by an article in the Bangkok Post in the Database section. That was maybe 2 weeks ago. I made a note to download Comodo as soon as I get back from my business trip. I do remember the author saying something about having connections to the internet problems.

Well anyways, I’ve been on my computer all afternoon trying to read this forum and figure out how to configure Comodo so that I can go online. I’ve been installing (not being able to be online) and uninstalling (back online) so I can read the forums.

I’ve tried everything, I THINK

I disabled “Do protocol analyses”

I’ve turned off the monitors.

I’ve set Comodo to “allow all” traffic.

But the bottom line is hat its blocking my internet from start up. When Comodo is installed, the modem doesn’t blink the way it normally does when I reboot.

I’ll post some screenies

Hope someone can iron out this for me because I unistalled Sygate and I dont have a backup firewall. (aside from the windows firewall) *NO I am not using the Windows Firewall at the same time as Comodo.

I dont know too much about setting rules. If there is a rule out there for DHCP please let me know!

(:WAV)

[attachment deleted by admin]

Hi steveo.

In some ways the second picture says it all. Something is clearly wrong with your installation. If you haven’t changed any rules in cfp, I might recommend re-installing. But before you do that, can you tell us what else you have changed?

Toggie

[b]Hi steveo.

In some ways the second picture says it all. Something is clearly wrong with your installation. If you haven’t changed any rules in cfp, I might recommend re-installing. But before you do that, can you tell us what else you have changed?[/b]

Thanks Toggie for your response…

I followed the instructions in the installation guide, posted in this forum with the video. I can’t remember the terminology used but it said to ad a safe zone and do a program scan.

After not being able to get online, I disabled protocol analysis and it didnt work.

How do I make sure there are no traces of the program left? -clean uninstall? (I used Your Uninstaller each time)

How do I install so that it doesn’t block my internet?

Yeah, steveo, I’m going with Toggie - something went haywire with your install.

A few possibilities:

  1. You’re on a 64Bit system (I think you’d have seen CFP error messages, tho)
  2. You had some other active security software running while you installed (antivirus, antispyware, HIPS, etc, with an ‘on-access’, ‘real-time’ feature)
  3. The original installation package was corrupted somehow

Your screenshot shows the default network rules, with the additional “trusted network” rules at the top; created by the Wizard. If you followed AOwl’s video tutorial, you shouldn’t have any problems. Even if you had gunked something up in the rules, setting to Allow All would bypass that.

The only thing I would check, prior to doing another uninstall/reinstall is to look in the Application Monitor for a block rule on svchost.exe; if you find one, you’ll need to remove it and reboot. I don’t think you will, as Allow All should bypass that as well, if it were present.

As far as the uninstall, do the following (we’ll take a few steps here, but it’s worth it):

First, download a new installation package from Comodo: Free Firewall - Download the Best Firewall Protection and Anti-Virus Scan Software from Comodo, just in case the previous one was corrupted somehow.

  1. Go to Start/Run, type “services.msc”; find Comodo Application Agent; change startup type to Disabled.
  2. Go to Start/Run, type “msconfig”; then Startup tab; find Comodo Firewall Pro and uncheck; Apply, and Close.
  3. Reboot computer.
  4. Run the uninstaller; follow the prompts, and reboot when finished.
  5. Clean the registry. If you’re comfortable searching and navigating, use Regedit (start/run, “regedit”); if not, use a utility like RegSeeker, ccleaner (be sure to make backups, which both these allow/recommend).
  6. Reboot again. (this is your 3rd reboot in this process)

Now you can reinstall. Prior to starting the install package, be sure to completely turn off/disable any Active security product, as mentioned before. Some may require you to turn off individual components before closing the program, in order for all to be truly turned off. You can turn them back on after you have completed the installation. If you don’t turn them off first, there is a good possibility they will interfere with CFP’s installation, with some strange results.

Hope this helps,

LM

OK, I followed your directions for uninstall. These are my current processes.
I will now install.

[attachment deleted by admin]

And again. Can’t online while Comodo is on my computer. Even if I shut Comodo down. Its doing something on start up to block my connection.

If I uninstall the program and reboot, Bingo back online.

PS. I followed the installation guide and turned off the Analyse Protocol.

Very frustrated.

After installing, have you gone to Security/Tasks/Scan for Known Applications? Follow the prompts and reboot.

Also, after you create your Trusted Network, be sure to reboot.

Let me do some digging and see what else I can come up with.

LM

Yes, I’ve been rebooting…thanks for all and any help

Okay, let’s do this:

With CFP installed, go to Activity/Logs. If there’s anything there, right-click and select “Clear all Logs.”

Then try to access the internet; you can use your browser, as that’s probably the simplest way. When it fails, go back to the logs, to see what’s there. Right-click, select, “Export to HTML.” Save the file. Reopen it, Copy the entries, and Paste them as text into your post here.

If CFP is actively blocking you, it will be there…

While you’re in CFP, go to Application Monitor. Open to Full Screen. Capture a screenshot, and attach to your post here, as you’ve done before.

TNX.

LM

As requested…thanks for helping

COMODO Firewall Pro Logs

Date Created: 23:04:20 16-03-2007

Log Scope:: Today

Date/Time :2007-03-16 23:02:32
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = x.x.x.x, Port = upnp-mcast(1900))
Protocol: UDP Incoming
Source: x.x.x.x:3090
Destination: 239.255.255.250:upnp-mcast(1900)
Reason: Network Control Rule ID = 7

End of The Report

IP Information in picture modified to protect user information.

[attachment deleted by admin]

So, a couple things:

At the point of this log entry, you have an internet connection with Comodo installed. Otherwise ipconfig wouldn’t give you the info it has, with your gateway, IP, etc.

You’re still in Bangkok? The IP in the log entry was from Maxthon ISP out of Bangkok, and matches your personal external IP address (which is why I edited it in your post).

Given that you have a router using NAT (evidenced by the 192.x.x.x IP addresses in ipconfig), your ISP might be attempting to establish contact with your machine, but it seems odd that they would be using a multicast protocol like this to do so. You might want to contact them and ask what you need to allow in a firewall in order to maintain connection.

You might try this next: Edit every Rule in the Network Monitor, to add logging to each one, by checking the “Create an alert if this rule is fired” button. When you’re done clear the Logs as you did before, and reboot.

Now Export, save, Copy/Paste your logs.

LM

I’m very far from Bangkok. But yes, I am in Thailand and my ISP is prob in Bangkok…

I have 2 questions…

  1. Does Comodo have any problems with AVG anti virus? I did turn it off for the installation, but after installing and rebooting, AVG comes back…

  2. I’ve tried to set up a static IP. Maybe I should check the options obtain ip address automatically and obtain dns automatically?

Anyways, I’ve spent HOURS on this today. It takes a long time to install/ uninstall and all the rebooting.

It’s late here and I’ll tackle it tomorrow.

Thanks for your help

Steveo

I think multicast is a side effect from your router not being able to send/receive data due to the wrong configuration. What i see and makes me curious is why your gateway address is the same as your dns address. Try to configure your router and network connection settings properly and you re good to go.
Little Mac as more experienced will give you the light

Tnx, I just wanted to clarify, and make sure I was looking at it correctly. :wink:

  1. Not that I’m aware of, like this. You’ll probably need to edit the application monitor rule for AVG’s email scanner, to Skip Advanced Security Checks (miscellaneous tab), but that’s common for AVs. AVG by default boots with the system, so that it provides “active” or on-access protection. This is normal, and is why we want to turn it off while installing… CFP installs into the core of the OS, and active AVs frequently don’t like that. AVG restarting when you reboot does not surprise me, and is not of immediate concern.

  2. For the moment, yes, I’d have it assign an IP dynamically, rather than static. Typically, your router will assign the same IP anyway. At any rate, since you’re having some problems at the moment, I’d let it run on “auto” so to speak, to see if that helps.

I understand the time factor. When you get back to the things I mentioned before, just let me know the results. We’ll keep plugging at it. :wink:

LM

A quick update:

I set up my internet connection to manual, no static IP.

I installed Comodo (again, maybe the 15th time)

Each installation takes 3 reboots.

Again my internet connection did not work.

I have to uninstall Comodo just to get online. If it’s on my computer whether its running or not, I can’t get online.

I give up. Zone Alarm worked on the first try.

[attachment deleted by admin]

What about a Winsock repair? I’ve never tried it, though.

You might have something there, soyabeaner. It’s worth a shot; this definitely shouldn’t be happening like that.

Now that I think about it, I think I recall reading something similar to that before. Odd situation, though.

LM

PS: Steveo, I admire your determination and “sticktoitiveness” ~ you’ve been a real trooper throughout. I understand if you choose just to stick with ZA at this point. If, however, you decide to keep plugging with it, we’re here to help.

Hello Steveo,

Yes as LM said, we are here to help if you choose to keep going.

What other security software are you using? One of them may be conflicting with Comodo which may be causing this.

Justin

Thanks for all the help…

OK, I’ll stick in there…

I ran winsock.

I installed Comodo again.

I’ll attach some screenies.

  1. One problem, after I entered email adress, the installer shows a black window with next, looks very unatural. See screenie.

  2. When defining the safe zone there are 2 choices, I chose the second one. See screenies.

  3. I am using avg, and spysweeper…

  4. I’ve attached my startup porgram, see screenies

All advice from here appreciated!

Steve

[attachment deleted by admin]

continuing,

During the security zone set up there are 2 choices…see attach

When Comodo was iniitalising, my IP had one address than changed…

I didnt catch the numbers because it happened quickly

[attachment deleted by admin]