Problem(?) with Comodo 2.4.19.185 on WinServer 2003

Hello,

I’ve been using Comodo Firewall Pro 2.4.19.185 on my Windows Server 2003 servers (version 3 does not support Windows Servers :'(), and I’m happy. Until just recently.

I’ve just installed CFP 2.4.19.185 on my Terminal Server. The strange thing is:

  • From a directly-attached console, CFP appears to be working
  • Everytime I connect using Remote Desktop, a Comodo error pops-up, telling me that Network Monitor and Application Monitor is not working, I may have to re-install Comodo. Double-clicking on the Comodo SysTray icon indeed shows all Comodo subsystems to have red X’s (off)

My questions are:

  • 1. When that pop-up shows, are the subsystems really Off, or only because the Comodo’s console somehow can’t retrieve the firewall’s status (i.e., the subsystems are actually still functioning)?
  • 1. a. If the subsystems are really Off, how do I turn them back on?
  • 1. b. 1. If the subsystems are actually still On, how do I allow Comodo console to detect their status?
  • 1. b. 2. Alternatively, how do I disable Comodo’s error pop-ups?

Thank you for your assistance.

Rgds.

No one? :o

Try the following:

  1. Problem:
    Installed CIS and now cannot get a Remote Desktop Connection.

Solution:
You have a blocked entry.
Ensure that remote desktop connection has been enabled.

Right click on “My computer”
Select Tab “remote”
Select “remote desktop”

Comodo Firewall on remote computer:

In the firewall section – in the left column, select “advanced” – network security policy – global rules

You have to allow TCP port 3389 IN thru the firewall. The firewall log should show that port as being blocked when you try to remote in.

The rule would look like this:
ALLOW - check the checkbox if you want to log
TCP
IN
Source IP: the IP of the PC you are connecting from
Destination IP: Any (or the IP address of the computer being connected)
to here)
Source port: ANY
Destination port: 3389

Now move this rule to the top, so that this rule is executed first.

In the firewall section– in the left column, select “advanced” - network security policy – application rules

Find the entry for svchost.exe
And change the part:

Block and log IP in …….

Add the exception for the IP address of the source computer