Problem with CIS 7 and PeerBlock

First of all I apologize for my English is poor quality, in fact, when I write, I’m using a translation engine from Italian into English; This is the problem I found in the latest version of the CIS 7 (v.7.0.317799):

I reinstall Windows, install the usual programs, then the usual security programs, removed Comodo Internet Security Premium (CISP), which was recently updated to version 7, and I notice that PeerBlock has no intention of working, in most cases when I go to update the lists I get this error:

Hence the image of the error:

I came to the conclusion that CISP 7 PeerBlock and do not want to work together, at least PeerBlock is no longer able to update the list if it is present in the system CISP 7, in fact, after scanning dozens and dozens of times with many different antivirus I realized that there is no malware on the system I am, I also tried to start from scratch with PeerBlock, or with a version storata in my pc in the form of encrypted file, so as to be sure that the source file is clean to 100%, but nothing, still the same error pops out, of course I also tried to re-download the zip file (use the portable version), but also here the same thing, it turns out always the same error!
The last way I tried, just to figure out what the problem was, was to use a virtual machine, and use the old version of CISP 6.3, in this case, no problem, even with 100 lists included in PeerBlock.

Please, I confirmed that this problem is present in systems where this is the latest version of Comodo Internet Security Premium 7, if not, tell me how I can fix, because I’ve tried everything to really, and I do not know which roads to take (! ), thanks to all for any help. :-))))

After some time:

I confirm fully what I wrote above, I can also add in more than now, after reinstalling my pc from scratch, again with the usual programs, but in this case with the previous version of Comodo, which is the latest version 6, the 6.3 PeerBlock has returned to work without any problem.

P.S. I also noticed that in the new version of Comodo 7, even the “Burd’s Proxy Searcher” (a seeker of Proxy server, as can be deduced from English) was not able to find any proxy (no longer working, the list is not is more populated with the results of the research), of course now, having returned to the previous version of Comodo 7, the 6.3, even Proxy Searcher is back to work properly, all the problems I have encountered previously with Comodo 7, now with Comodo 6.3 resolved.

Can anyone confirm these problems and / or possibly tell me how to solve them? Thank you all for any response :-).

I have also encountered this from time to time. However, my system has other issues and it was never reproducible.

In order to forward this to the devs I must ask that you format your first post. Please copy and paste the format from this page into your first post. Just copy and paste it, then replace the question marks with your responses. Please do not edit the formatting.

Let me know if you have any questions.


PM reminder sent.


I confirm that CIS 7 and PeerBlock works harmoniously togather as well as enhances each other.

It would be really stupid if Comodo devs work on the opposite.

My system config is:

Win 7 Ultimate in 32bits.

There is absolutely no problem, whatsoever.

I have experienced the same error message on my own computer from time to time. Therefore, it would be worth looking into as a bug as how well programs work can vary drastically from system to system. It’s entirely possible for it to work perfectly on your system, but not on his. The most likely reason for this would be different programs running in the background, but there other possible explanations as well.

However, papatermi2014, if you do not supply the requested information, in the format I linked to, there is no way for me to forward this to the devs for investigation.


As there has been no reply I will assume that this issue is no longer occuring. Therefore, I will move this bug report to Resolved.

papatermi2014, if you are still experiencing this issue please edit your first post so that it is in the format I linked to. Then reply to this topic letting me know you have made changes.

Thank you.