Problem with CIS 5.4 (D+) and Firefox 4.x , IE9 [Issue Report]

The bug/issue

  1. What you did: Wanted to type “[at]” in Firefox and it didnt appear.
  2. What actually happened or you actually saw:
  3. What you expected to happen or see:
  4. How you tried to fix it & what happened:
  5. If its an application compatibility problem have you tried the application fixes here?:
  6. Details & exact version of any application (execpt CIS) involved with download link:
  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
  8. Any other information (eg your guess regarding the cause, with reasons):

I had to install CIS 5.4 over CIS 4.x cause i had some bug/issue there. I could save my CIS4 config, cause the config window didnt show me any config, also there were some. So i override the old installation and hoped, that everything works fine. It wasnt so.
I have set Firefox in D+ to custom rules, and evything was set to allow, except of file execution, modify files/registry. When i started Firefox it could resolve any DNS Name, cause it was blocked with an D+ Logfile entry. But with IE9 it works. Firefox was also blocked for accessing the keyboard, so i cant type any “[at]”. I have removed Firefox from D+ and from safe files, too. When i started Firefox again, i didnt get any question by D+, and no entry in the D+ ruleset appears for Firefox. But Firefox was set as safe file again. So i wasnt able to solve the problem. After that i tried this things with IE9. I set the D+ reulset for IE9 to the same settings like for Fifo, and everything worked fine.
Than i blocked the keyboard access and the access to DNS/RPC Resolve. I get a D+ Logfile entry for both action, when i started IE9 and typed an “[at]”, but IE9 could open every site and also “[at]” appeared. I only allowed svchost.exe for DNS Resolving, so if IE9 is blocked for accessing this, how could it resolve DNS for sites, i havent been before.
The only way, to solve this problem, was an uninstall of CIS5. I reinstall of Windows and CIS doesnt helped.
It’s first time, i have issues with CIS, and i use it since Version 3.0.
If you want my config, i will post it as PN, if possible.
Your set-up

  1. CIS version, AV database version & configuration used: CIS 5.4, up to date
  2. a) Have you updated (without uninstall) from CIS 3 or 4: Updated from CIS 4 to 5
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: Reinstalled CIS with and used the exported CIS 5.4 config, doesnt helped
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): set CIS to high security level, also blocked all unknown, agressive Execution Control
  5. Defense+, Sandbox, Firewall & AV security levels: D+= safe Mode, learn action by safe files , Sandbox= off, Firewall = custom , AV = on access
  6. OS version, service pack, number of bits, UAC setting, & account type: Win7 Pro 64bit, UAC standard, Admin
  7. Other security and utility software installed: no
  8. Virtual machine used (Please do NOT use Virtual box): no

Thank you for your Issue report.

Moved to verified.

Thank you


Nothing happened in last updates. When will this issue be solved?

Oh great, newest version seems to have solved it. Now i can use CIS like expected.