Problem with beta

For the past few weeks I’ve had problems deleting files/folders of products that I uninstalled. I always get an access denied message or someone else is using the folder/file. I have to reboot in order to delete these folders/files.

Realizing that my problem occurred around the same time I installed the new CPF beta I decided to test out my theory that CPF is somehow involved.

A little while ago I installed FireFox and then uninstalled it soon after. When I tried to delete the folders it left behind in a few places I got the usual error messages and I could not delete them.

At this point I used the CPF tray icon to EXIT the program. When this was done I tried to delete the folders again but I got the same messages. So I killed cmdagent.exe. VIOLA, I could now delete all the folder/files I couldn’t delete before. No reboot needed. This is the way things always worked before the CPF beta. I rarely had to reboot. With CPF beta I have to reboot all the time unless I kill CPF.

So it appears CPF is grabbing these folders/files when I uninstall products and never letting go of them.


Yeah, I had this problem too!!!
Do you have CAV 1.1 beta installed?

Not using CAV at all. Using AVG Pro.

I also posted a problem that when I shutdown/restart/logoff XP I sometimes hang at the logging off screen. I am now wondering if this is happening as a result of uninstalling something prior to the shutdown? I haven’t had this problem in a day or so but I also haven’t uninstalled anything either.

egemen… you reading this? Is this a known issue???

I would not call your issue something that is known/normal. I have been able to uninstall/install things at will with CPF running. Sometimes applications require reboots after an uninstall, as a service or resident app prevents the uninstall from happening 100%; in these cases, the residue left over is scheduled to be cleaned out after the next reboot.

But lets try prove what you are reporting. Please download and install WhoLockMe. It will show all processes that have a file/folder locked (and allow you to kill them).

It is not a case of an uninstall needing a reboot, this I am sure of. When I completely kill CPF and CMDAGENT I can delete the folder with no problem whatsoever.

I did try to check to see what was locked using a program called unlocker. Traversing down the folder chain to what might be locked I will eventually get a message that tells me that access is denied because the program might be in use by another program. Unlocker as a result can’t even tell me if it’s locked but I presume it is by the error message. Of course I can’t use unlocker to unlock it.

I’ve has a number of problems with the beta related to accessing folders/files of one sort or another.

One of the builds did fix one of them but introduced a few others.