Problem running the OED with Comodo [RESOLVED]

I have a problem running the electronic version of the OED (Oxford English Dictionary) concurrently with Comodo Firewall Pro ( on my system (XP SP2).

The OED uses an anti-theft software called “CD-Cops”. Each time I launch the OED, “CD-Cops” is actually launched first and creates a temporary file with a different number to keep track of how many times I launch the dictionary before I have to reinsert the original installation CD-ROM into the drive. So these “.TMP” files all have different numbers and their extension is not “EXE”. But they behave as executables: they change local files, inject processes into memory, run other executables. They are all named in the same way, for example, “~crf2422.tmp”, but the actual number is different each time the dictionary is launched.

As things stand, Comodo Firewall Pro simply will not allow these TEMP files to execute properly. I invariably get an error message saying “Fatal Error 1007” and the dictionary is never launched. I have tried to allow everything relating to the dictionary. I have tried to register the OED executables as trusted applications. To no avail. I would need to register the TEMP files as trusted “applications” but this is not possible. It would be possible if I could register TEMP files as executables, and if I could register them with a wild card pattern. Something like “~crf*.tmp”

Can anyone suggest a workaround?

Thank you very much for any help.

Have you tried entering CD-Cops into D+ at Computer Security Policy as Installer/Updater? And running the whole thing in installation mode? Maybe OED also?

I have tried registering all the files in the OED folder (DLLs, EXEs, logs, etc) first as installers/updaters, then as trusted applications. To no avail.
Each time I get this kind of message:

“~CRF2645.TMP is trying to access the disk directly.”

And immediately afterwards:

“Fatal Error 1001”.

By the way, there is no visible CD-COPS executable, but there is a “CDCOPS.DLL” and a “QZCOPS.LOG”. Also there might be more hidden CD-COPS dependencies. The “~CRF*.TMP” files themselves apparently behave very much as executables.

I would need to allow absolutely all activities for the OED and all potential CD-COPS dependencies. But it does not seem possible in Comodo. Alternatively, I would need to be able to register the “~CRF*.TMP” files as trusted applications.

As things stand, I have to shut down Comodo to be able to run the OED dictionary at all.

Thank you for any help.

Have you tried installation mode also? That seems to support some additional installer quirks.

Hi Robert,

Try to do the following: find out in which folder those ~crf*.tmp are created. Add that folder to computer security policy of defense+ with wildcard character , e. g. c:\OED_temp_folder. Declare that folder as “trusted” or “windows system app”.

Thank you ever so much for the tip, goodbrazer.
These “~CRF*.tmp” files are routinely stored in “C:\Windows\Temp”.
All I had to do was to register “C:\Windows\Temp~CRF*.tmp” as a “Trusted Application”.
Thanks again!

I don’t know what to make of this. Registering “C:\WINDOWS\Temp~CRF*.TMP” as a “trusted application” worked for a while. And then, for completely unexplained reasons, it stopped working.
I tried to register “C:\WINDOWS\Temp*.” as a “trusted application”. It allowed me to run the OED but Comodo is still popping up messages about each new “~CRF.TMP” file because these files are running “CMD.EXE”. I tried to register “C:\WINDOWS\Temp~CRF*.TMP” as a “trusted application” again. To no avail.
I have run out of ideas.

Any suggestions?

So you receive message from Comodo that “xxxxxCRF.tmp tries to execute cmd.exe”? If so, declare “C:\WINDOWS\Temp~CRF*.TMP” as “windows system application” to grant permissions to ~CRF*.TMP file to execute any executable silently.
If no result, try to play with wild characters, e. g. instead of C:\WINDOWS\Temp~CRF*.TMP use C:\WINDOWS\Temp*CRF*.TMP etc.

One more variant to try is to declare CMD.EXE as “windows system application” also.

I registered “C:\Windows\Temp*CRF*.TMP” as “Windows System Application”.
And “C:\WINDOWS\system32\cmd.exe” also as “Windows System Application”.
This did the trick. The OED is now launching and running normally.
Thank you very much for a great help, goodbrazer!

Cool, glad you have it configured now :-TU

Thread will be closed now. If issue returns PM any on-line moderator to open.
… And i think thread suits better for “help for v3” board.