Problem Running Cameyo Packaged apps with Comodo Firewall

I seem to be having a problem running Cameyo packaged virtual apps on systems where Comodo CIS or Comodo firewall is installed. The first time you go to run a Cameyo packaged app (I have been testing with CPU-z) it usually runs fine…after a few prompts from the Firewall. The second time it is run it gives you an error 3 cannot execute program and stays this way.

I checked both defense plus and the firewall and the file is not being logged on either one. I have also tried to trust the file with no success. I have also tried to disable all security and it still doesn’t run. Exiting comodo doesn’t work either. The only way I could get the program to run is to fully uninstall Comodo. Can someone please tell me why this is happening.

Thank you for your time

Try adding the application to the Exclusions of Detect shellcode injections (i.e. Buffer overflow protection) .

In case that does not work can you provide us with a download link for Cameyo packaged CPU-Z?

Wow! You are good!

That was definitely the problem. However I did notice what may be a bug.

If I go and untick the “Detect shell code injections (I.e. Buffer overflow protection)” I still can’t run the file unless it is in the exclusion list. That would probably also explain why I disable comodo protection and detect shell code injections still appears to be “on”

Thank you again and could you please look into that issue.

Here is the cpu-z file

Shellcode injections (BO protection) is a usual suspect that can sometimes interfere with operation of programs.

I did a bit of testing with cpu-z cameyo packed on Win 8 RP and noticed it won’t give any information other than under the tabs of CPU and Caches where the regular CPUz will give all information. The cameyo packed version does not run in the sandbox.

How did you disable D+? Did you just move the D+ slider down or did you use Deactivate Defense+ permanently (Requires a system restart)?