Problem re-installing CFP Version 3 [Resolved]


I had to uninstall CFP, for reasons unconnected with this posting, and when I tried to re-install it there was a message saying that CFP is already installed and asking if I wanted to uninstall it. When I clicked on ‘Yes’ nothing happened so I re-booted and tried again re-install it and got the same message.

CFP is NOT installed on my computer even though the installation program says it is. Presumably there is a file somewhere on my hard disc that makes the re-installation fail. How can I find what the file is and delete it so as to re-install CFP? If it is not a question of deleting a file, then how can I re-install CFP? I noticed that in 'Administrative Tools/Services" Comodo Firewall Pro Helper service" is running and that there are various files to do with CAV in a folder called CAVAspy

I have removed as many references to it that I can find in the registry, but that has not helped either.

For the record, I am having exactly the same problem with CAV - I had to remove that and now I can’t re-install it either. Can anyone help with that too, please?



For CFP 3, read this thread.


You need to follow the steps in this sticky. Get into the habit of using Revo Uninstaller in advanced mode also. I never have any problems uninstalling anything.

Thank you both for your help. I now have CFP working properly again. Sorry it took so long to get back to you; I have had visitors and I am not “allowed” to switch the computer on when they are here.

Don’t worry about it :wink:
I’ll close this topic now that you’ve solved the problem. PM an online moderator with a link to this topic, if you would need it opened again.