Problem downloading free email cert

This is hopefully a simple problem since I can’t find anything related in the forums of knowledgebase:

  • I requested a certificate using IE7.0.5730.11 on XP Pro SP2
  • When I attempt to download the cert, I get a message saying “This Certificate could not be installed. Please ensure that… this is the same computer and web browser from which you applied for your Certificate [it is] you have not deleted your Private Key [I didn’t] you have not already installed your Certificate [I haven’t]”
  • If I look at the cert in IE (there’s one there, even though it said it couldn’t download it – and I’ve tried deleting it and trying again), it says it has an associated private key
  • If I try to export the key, it says it does not have a private key
  • I cannot decrypted email messages with the cert
  • I can successfully request and download the cert with firefox, so it looks like a problem w/ IE

I’ve revoked and retried 3 times on two different PCs.

Both PCs have Norton AV…don’t know if there is a known issue there.

Any ideas? I can’t be the only one with this issue! (:AGY)

I have exactly the same problem. But I was not able to revoke mine and retry.

I have the same issue too and just stumbled on this forum post.
I have requested revocation of the cert to try again, but I have the exact same IE version and same error.

Also, if you check, there is an entry in the personal cert store for this cert, but it is just not correct in some way. You cannot use the cert, or export the cert it is corrupt and cannot find the matching private key.

Did you get any updates ?

My next plan is to try firefox (when support revoke it), then export the cert and import into IE.

Normally this issue will be resolved when you revoke the current email certificate. If you have still having the problem then please submit the ticket in support.comodo.com, and mention what exact error you are getting.

Thank you for your patience