Problem downloading 64-bit version

I just installed Vista SP 64-bit version on a separate partition. When I try to download the 64-bit version of CIS, the d/l box tells me the file size is 9.7MB (instead of the 39.9MB announced on the d/l page), and of course the resulting downloaded file is “not a valid Win32 application”.

Could someone give me a valid d/l link, pretty please?

This one should be fine AFAIK


Thanks, but unfortunately this is the link that doesn’t work properly: the d/l button resolves to it in the status bar, and I tried typing it manually in the address bar :frowning:

Edit: just tried with Opera, same results. Free Download Manager also reports the same incorrect size (9.7MB)

Odd, I successfully downloaded it (40 MB) in Opera from the link above. ???


Strange ??? Then something must be blocking it. I just downloaded it the same way …


I am also trying to download the 64bit version.
The link you provided links to a corrupt 9,7 MB file.

Can anyone here please upload the correct file somewhere and give us the link?


I wonder if the downloader’s location doesn’t have an influence, if there are several d/l servers that are automatically dispatched depending on the client’s IP address…

Then try this link, see if that one works


You nailed it.

I asked a friend in Canada to download the file and send it to me via MSN.

I wonder how many other people in Europe cannot access the file.


Ok, I’m from europe (belgium to be exactly) and I can download it ?


I do not know if this info might help solve the problem, but that link too points to a 9,7 MB corrupt file for me (in Italy).

Then you have some malware I guess…

Could you visite other sites and AVG and try to download their stuff to see if that worked ?


I’m also in Europe (Sweden). (-www-)


I tried from 4 different PCs.They are all clean.
I have tried using IE, FF and Opera. Same results (I only get a 9,7MB file).

I can download other files from any site with absolutely no problem.
I would also like to mention that the 32-bit version of CIS downloads fine.

I have asked people in Portugal, Romania and Germany if they see the “complete file”. They all replied that the file size for them is 39,9MB. I will try asking other Italians later (that use different Internet providers than I do).

Now, as stated above, I have managed to get the 39,9 MB file through a friend. So my problem is solved.
But it would be nice to know why I am seeing a file that is only 9,7 MB big? (same as the topic opener).

Does Comodo use a particular server for Italy?


I have added a screenshot just to show you that I am not making this up…

[attachment deleted by admin]

Unfortunately, this does not solve my problem either (see attached pic) :frowning:

Edit: Just for complete information, I’m located in paris, France.

[attachment deleted by admin]

Have you tried this link?
The file size is correct as I just checked it.

This one works, many thanks :slight_smile:

I’d guess some of the mirrors, or at least one of them, did not receive the full file for some reason.

Yes, I get the correct file size from Rome, Italy.