Proactive Security Freezes Vista notebook PC

Comodo Firewall proactive security setting freezes my Vista notebook PC

A. THE BUG/ISSUE:Switching from firewall security to proactive freezes my laptop.

  1. What you did:Activate proactive security
  2. What actually happened or you actually saw:Vista OS froze and would no longer respond
  3. What you expected to happen or see:I expected proactive security to work.
  4. How you tried to fix it & what happened:I tried several solutions posted in the Comodo forum and none of them fixed the issue.
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?:N/A
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):Comodo Firewall 5.9.219863.2196
  7. Whether you can make the problem happen again, and if so precise steps to make it happen:All I need to do is activate proactive security.
  8. Any other information (eg your guess regarding the cause, with reasons):No clue as to why it happens.

B. FILES APPENDED. (Please zip unless screenshots).:N/A

  1. Screenshots of the Defense plus Active Processes List (Required for all issues):N/A
  2. Screenshots illustrating the bug:N/A
  3. Screenshots of related CIS event logs:N/A
  4. A CIS config report or file:N/A
  5. Crash or freeze dump file:N/A
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version:N/A

C. YOUR SETUP:Comodo Firewall / Avast Free antivirus

  1. CIS version, AV database version & configuration:N/A
  2. a) Have you updated (without uninstall) from a previous version of CIS:No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:yes
  3. a) Have you imported a config from a previous version of CIS:no
    b) if so, have U tried a standard config (without losing settings - if not please do)?:no
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):no
  5. Defense+, Sandbox, Firewall & AV security levels:Safe Mode / Disabled / Safe Mode
  6. OS version, service pack, number of bits, UAC setting, & account type:Vista / SP2 / 32bit / UAC active / Administrator
  7. Other security and utility software currently installed:No
  8. Other security software previously installed at any time since Windows was last installed:Norton Internet Security
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]:No

From the information you have given I am not clear whether this is a bug/issue.

For the moment I will transfer you to help so you can work through this issue with users and mods in this forum and hopefully resolve it. I hope that is OK.

Please ask any mod to move this report back to the bugs forum if it becomes clear that it is a bug/issue.

In your particular case I would try the following.

  1. Turn off ‘enable enhanced protection mode’ under Defense plus settings and reboot
  2. Use the forced uninstaller tool to ensure complete de-installatiuon of Norton Internet Security and reboot

People in the forum will explain exactly how if you ask. If you ask for your issue to be moved back to the bug board you will need to say that you have tried out this suggestion.

Try importing a factory default Proactive Security configuration, activate it and see what happens.

You can find it in the CIS installation folder. When importing it you will need to give a name. Give an appropriate name like Clean Proactive Security or so.

@mouse1, option 1 seems to have worked. First I was in firewall security mode, switched to proactive and rebooted, and when back I unchecked “enable enhanced protection mode” and rebooted. When back, I tried all sorts of things that would have caused the freeze before, but now everything seems fine, no more freezes. What does this tell you?

It tells us that you should leave enhanced protection mode off.

It is mainly intended to improve the security on 64 bit OS’s. (As I understand it)

The reason it is an option that is off by default is because the developers felt it may cause problems on some machines.