Privdog on a Standard Users Account

Hi all.

I have Privdog installed OK on Main/Administrator Account.

I also have a Standard Account which I run all the time for Security Purpose.

The Problem I’ve got I can’t seem to install Privdog over to my Standard Account and use it in Ice Dragon.

It says Privdog is already installed.

It seem to Work OK when I had Dragon installed.

But due to Problems with CIS 6.2 It seems to have blocked access for me to install Dragon back

So that is why I’m on Ice Dragon and all works great apart from Privdog.

So any info or advise will be good.

Thanks in advance


Thank you for your post :-TU. I will check this case.

Thank you NPoberezhnaya

Hi Nige_39,
Try dropping the .xpi file found in the attachment into an open window of IceDragon in your standard account.

[attachment deleted by admin]

Also I Manged to Fix Comodo Dragon and Privdog works real good under my Standard account

Also to help you NPoberezhnaya I uninstalled Privdog on my Administrator Account and gone over to my Standard Account and Install it. But it came up enter your Password so I did and Privdog Installed OK.

Then I closed Ice Dragon and opened it, and Noticed it not there.

So then I Switched accounts and opened up Ice Dragon and to my finding Privdog loaded up OK there.

So it’s a shame that Privdog don’t get loaded into Ice Dragon like it does on Comodo Dragon.

So I’ve told you everything now

So I hope this Helps



Hello captainsticks,

I downloaded ZIP file.

I have tried to drag the white folder over to a blank area of the top right and it does seem to happen. I dragged it over between Comodo Web Inspector and Display your bookmark icon. but I can’t seem to get it to stay.

So any advise Please



Hi Nige_39,
Sorry I am not sure what to suggest as my Drag’n’Drop method also fails on my Win 7 system for some unknown reason, but it works fine with my Vista system. :-\

Hi Captainsticks,

It is very strange, on what you have just told me.

Funny enough I have a Vista 32 Bit Laptop and Windows 7 Main Computer.

What I have notice. on Vista. I can drag over the XPI file and take it to the top right. But under the white file it has a red circle with a strike though the center.

So if I drag it over to the area of Bookmarks a small text icon shows up with a Blue + Icon and copy next to it. And I can only seem to make it go to Bookmarks and know where else.

It happens the same if I do it on my Windows 7 Computer.

So Lets hope they put Privdog in up coming version of Ice Dragon. Just like that have already in place for Comodo Dragon.

So captainsticks I don’t know what else can be done.

Thanks again



I have Just tried to see if Privdog loads up OK on the Standard account.

So the Answer is NO it does not show up on Firefox on the standard account.

But I runs OK on the Administrator account.

So It’s not just Ice Dragon has the issue, it is also Firefox.

I just thought I let you all know



Thanks for the feedback :-TU It is very important for our team. We have a ticket. I hope that programmers will be fixing this issue as quickly as possible

Thanks NPoberezhnaya :-TU