Printing in Office 10 Starter blocked by Comodo[V5]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:Set Defense+ to Safe Mode and Office 10 Starter (Word/Excel) gets ‘no printer found’. Reduce to Clean PC Mode and Office prints just fine.
  • If not obvious, what U expected to happen: Expected printing to be fine with either setting. It was for a year, and recently stopped cold (if in Safe Mode).
  • If a software compatibility problem have U tried the conflict FAQ?: Yes
  • Any software except CIS/OS involved? If so - name, & exact version: Office 10 Starter
  • Any other information, eg your guess at the cause, how U tried to fix it etc:I may have replied ‘block’ at some inopportune time. If so, I don’t know how to find it and ‘unblock’ it to get Comodo out of the way. But, that may not be the cause. I don’t know.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:D+ = Clean PC Mode, Sandbox = Enabled, Firewall = Safe Mode, AV = n/a
  • Have U made any other changes to the default config? (egs here.):Not intentionally
  • Have U updated (without uninstall) from a CIS 5?:No
    [li]if so, have U tried a a clean reinstall - if not please do?:n/a
    [/li]- Have U imported a config from a previous version of CIS:No
    [li]if so, have U tried a standard config - if not please do:n/a
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:Windows 7 Home Premium 64 bit SP1, UAC = Default (Notify me only when programs try to make changes to my computer), account type is ‘free’?, no V.Machine. Comodo is 5.12.256249.2599
  • Other security/s’box software a) currently installed b) installed since OS: a= Avast b=nothing that came with OS, installed Comodo and Avast after initial boot.
    Anything else needed (screen shots, etc.), please reply with specifics how to get it. I know a little bit, but not a lot.

Is this perhaps related to the bug report which has already been filed here? There is already a known incompatibility between Office 10 starter and CIS.

It may be. I did read that before posting. But there are at least 3 significant (to me) differences.

  • I have found that using the “Deactivate the Defence+ permanently” option removes the problem.
  • I have found that all other attempts to configure Defence+ to avoide the problem do not help.

For me, this is not true. All I have to do is slide the Defense+ scale down 1 from Safe Mode to Clean PC Mode.

  • I have found that there are no entries in the event log to help with the problem.

Again, not true. As noted in my problem report, I have event log entries that may help someone, but they don’t help me because I am too unfamiliar with how all of this stuff works.

  1. What you did: Start Microsoft Word Starter or Microsoft Excel Starter.
  2. What actually happened or you actually saw: After a few seconds a splwow64.exe application error is displayed: “The application was unable to start correctly (0xc0000005).” Both applications are then unable to print.

I get no error message on start up. In fact, as noted in my report, it worked with no errors for a year. It printed without fail. Now Word/Excel fail to print without exception when Defense+ is in Safe Mode.

I read ‘format verified issues’ but did not exactly learn how to report using the proscribed format. If needed, can you direct me to that. Clearly, I have ‘solved’ my problem by moving Defense+ to Clean PC Mode. But the whole thing struck me as so strange, since it always worked before, that I thought a simple answer to return to working the way it did before might be possible.

I have Firewall and Defense+, but no Comodo AV (Avast instead). I have no idea how to learn more about my Sandbox and Sandbox settings. The referenced problem report called it ‘disabled’ - given my event log entries, I am certain it is not disabled, but I am not finding a tab in Comodo to learn more about Sandbox contents and settings and actions.

Okay, now I understand. In that case we will need a formatted bug report for this.

Please edit your first post and use the format provided here. Just copy and paste the code and put in your answers after the colons.

Also, attach your diagnostic report and the KillSwitch Process List. If you have any questions about how to do any of that please feel free to ask. I’d really like to see this bug fixed.

Thank you.

PM sent.

I will move this to the non-format verified section of the forum, as not enough information is required to forward it to the devs. Please put your report in the requested format. I would really like to see this fixed, and forwarding this to them is the only way to get it fixed.

Also, please be aware that files in the non-formatted section of the forum are only rarely looked at by the devs. Thus, in order to get this fixed please attach the requested information and send me a PM. Please feel free to ask me any questions you may have.

Thank you.

I noticed from your bug report that you mentioned that you are running V 5.12. Unfortunately Comodo is no longer accepting bug reports from V5. Many issues are already fixed with V6.

Can you please download Comodo Firewall V6, which can be found here, and see if the bug still exists with V6. This will also give you the ability to ensure that it was not just a accidental setting you created which caused this. I would advise following the advice I give here for updating. This will ensure that none of the older settings, or changes to the configuration, carry over.

As this was created for V5 I will move this to Outdated. Please send me a PM if you find that the same issue still exists for V6.

Thank you.

I am now on 6.2.285401.2860.
The problem has disappeared, so you can close this report - Defense+ and Firewall are both in ‘Safe’ mode and Office starter can print fine. A couple of closing comments:
While on Comodo 5, I clicked ‘check for updates’ and it came back ‘no updates, you are current’. But, I went to your web site and downloaded 6 anyway, per your request.
Initially (last night), very basic sub-second browser actions were taking 15-20 seconds. It was driving me crazy. But, today, not so much. So, perhaps it was going through early install growing pains.
In any case, thanks for your help.

With V 6.2 there shouldn’t be any browser slowdowns. This sounds like something didn’t go as planned during the installation. Please try reinstalling by following the advice I give here and see if that fixes the slowdowns.

That was yesterday. Today no problem.
I should add that, when installing Comodo I was told I had to do a system restart.
I did.
Then it did whatever it did and said I had to do a system restart.
I waited until end of day, because I find installations that require system restarts quite annoying and didn’t want to mess with it at the time.
I don’t know if it was Comodo, or my failure to do a timely system restart, or something else, but today I have no slowdown problems.

Strange, only one restart should be required, unless you made a change in the configuration (such as switching to Proactive security) which required a system restart. However, as long as everything is now working correctly I suppose there’s nothing to worry about.

If something does go wrong please create a new topic in the HELP section of the forum. This will allow many other users to contribute ideas as well. Barely anyone enters this particular section of the forum as it is not where users ask for help.