Prey isn't trusted, even when adding it as a trusted app.

Hi, even after adding Prey and it’s bash.exe to my trusted applications, I still get prompts as the following:

Since prey keeps creating different entries like this as part of it’s operation, I don’t want Comodo to keep prompting for this.

Besides, Prey is supposed to be running unnoticed in the background (it’s an app that allows me to various things if my laptop should get stolen), needless to say, if a thief has my laptop in hands I don’t want him to get a popup to ask if he wants to block Prey ^^

Any ideas how to allow any activity by this bash.exe?

if you search “this exe” in the defense+ rule list (defense, computer security), you can press “change”, with right click on it, or on the right side after you ticked the entry. and in the opening window is a little “grey underlined word” on the right side, like “customize” or like that. i dont know the english userinterface. but you will see what i mean.
then a list pops up. you can choose allow, block, or ask for different aspects for the selected aplication. allow creating folders, or what else is needed.
i dont know that program you are talking about, but make sure in any cases that it works like it should! and make a password control for comodo (more—settings----parental control). there you can also choose to supress questions of comodo… but you should have all working before you use that supressing. it would avoid a thief to be able to do anything like blocking, allowing or changing in comodo… even deinstallation is a problem then. dont forget that password, and dont forget that questions are supressed! :slight_smile:
hope that helps.
oh, dont forget to press all given ok buttons after changes, until the last window is closed and you see the normal userinterface window. or you will wonder why theres no effect :wink:

Super! That did it! I had no idea there were logs and settings there also =]

When I clicked Defense+ → Computer Security Policy → Defense+ Rules I fond the application (bash in the Prey directory) mentioned there.

Via Edit → Customize , I saw “Run an executable”, but no “allow” option. I could under Exclusions click Modify and then say “Allowed applications” → “All applications” ^^

So, got it thanks to you! =]

sure. there is no allow button for start other applications, because usually a program doesnt need general rights to start whatever it wants. in your defense+ window the bash exe tried to create a folder. it didnt asked for run a program. only allow what is defintely needed!

i would suggest to specify and reduce such allow rules as best as possible. your bash exe is now allowed to start everything :frowning: … what if a thief has a program that disables the bash exe after the bash exe would start it? just a scenario… then the password and supressing questions would have no effect.

if you let this rules be valid, make sure that you erase such rules when you de-install those exes one day.

That’s sound advice.

In my case, to safe myself some headache I’m going to stay with the slightly too open rule. But I’ll be sure to remove it when I remove Prey.

Thanks for the help!