Preventing the Firewall from starting when booting the computer

How do I shut down Comodo completely so that it doesn’t load when the computer boots?

I tried using Exit after right-clicking on the icon down in the system tray. It told me Comodo was no longer protecting my PC. Fine, ok, that’s what I want.

But then when I rebooted the computer the firewall was loaded again.

How do I prevent the firewall from loading up in the boot sequence?


Where do i find the “comodo application agent”? I don’t see it listed under either the Application Monitor or the Component Monitor. Or do I need to create a new rule in the Application Monitor?

And re cpf.exe. Is it really that technical? I’ve got to mess w/ the registry?


Depending on exactly what you’re wanting to accomplish, or your reason for doing so, you can simply remove CPF from the startup list. The service will still be active, and all you’d need to do to run/start the firewall would be to open the application window (ie, Start/Programs/Comodo/ComodoFirewall, or double-click the desktop icon).

To remove from the startup list, go to Start/Run and type “msconfig”. When the System Configuration window opens, go to the “Startup” tab. find the entry for “CPF” and uncheck the box. Click Apply, then OK. You will need to reboot for the changes to take effect.

When you reboot, Windows will give you a notice that you’ve changed the startup configuration. It will continue doing so every boot unless you check the little box not to remind you again, and then OK.

Just as a question, why do you want to keep CPF from starting when you boot?


PS: Welcome to the forum! (:WAV) You should find plenty of helpful people here, both users and Comodo staff.

Thanks everyone for the assistance and the quick replies!

Little mac - I think I could follow your suggestions. However, your comment “The service will still be active,” concerns me. I want to get Comodo completely out of the way.

Here’s some background:

I’m having difficulty connecting to my AT&T DSL service with a new computer. I want to rule out Comodo as the problem.

With my previous computer, all I had to do was simply disable Zone Alarm briefly in order for the AT&T install process to take place (allow the computer to find and communicate with my DSL modem).

However, with this new computer, even after “allowing all traffic”, or after exiting out of Comodo altogether, the install process still fails to recognize the DSL modem.

I want to make sure Comodo isn’t in the way. And if I have to uninstall Comodo completely to do it, I will. But I’m open to suggestions.

Press Ctrl+Alt+Delete and right click cpf.exe and close that process.
Press Ctrl+Alt+Delete and right click cmdagent.exe and close that process.
That works for me, but if it doesn’t for you, or if you want to be sure that it doesn’t start from boot, you should do as I describe below.

Turn off cpf.exe autostart like Little Mac say, in msconfig.
Then you should go to control panel and click on Administration tools and then Services.
Find the Comodo Application Agent. Double click it, set the start to manual or disabled.
Reboot your PC.

Also with CPF, you may need to run the Network Wizard (Security/Tasks/Define a new Trusted Network - lower left); I also recommend running the Application Wizard (Security/Tasks/Scan for Known Applications - lower right), then reboot. I have not ever had to run the Network Wizard to be able to communicate with router/modem for the DSL connection. However, some people do have problems, and this seems to resolve the majority, if not all (that I have seen).

So keep that in mind. I am very confident that you will not have uninstall CPF in order to get it working.

Following AOwl’s more detailed instructions will completely turn off every aspect of the Comodo Firewall, which will take it completely out of the equation. In order to turn it back on, you would need to follow the steps, backwards…

Hope all this helps. If you need any clarification, or run into any problems, please don’t hesitate to post back with more. We will help you get there. :wink: