Predefined Policies problem

Hello,

I’m new on this forum and I could not find a thread about a small problem I have with my Comodo firewall.

When I add my custom predefined policy in the firewall everything seems to be ok. But when the firewall asks to allow or block a program that is trying to make connection my custom policy doesn’t show up in the menu. The menu only shows the default policies (web browser, email client, ftp client etc.).

Can someone please tell me how to fix this one. Thanks in advance!

Thats because you can make predefined policies for defense+ and firewall seperately.

Have you rebooted since creating the policy?

[attachment deleted by admin]

Is a reboot now necessary?

It shouldn’t be, but I’ve seen it work in the past.

Yes, I have rebooted since creating the policy. Also, my defense+ is disabled.

Am I missing something or what? ???

Not that it should make a difference, at least as far as I’m aware, but are you running under any kind of limited user account settings?

No, I have admin rights if you meant that. :slight_smile:

More or less, I was just wondering if you running as Administrator/Member of Administrators or using some sort of LUA/SRP setup but that doesn’t seem to be the case.

Unfortunately, I can’t think of any reasons why this isn’t working, the new policy appears to be available and you’ve rebooted. So I’m afraid we’ll have to wait for some other ideas.

Yeah, seems like it but thank you for your concern! :slight_smile: :-TU

Your not the only one… I created on for called “Loop-Back Only” allowing only loop-back traffic. Sometimes it will show up in the drop down and other times it wont (speaking of only Firewall Alerts of course). My temp fix is I either allow/block with/without the remember option and then go into the firewall and apply it manually. It is a little bit of a pain.

If you look close, you may notice that the predefined rule for email client is missing too in that list. Scrolling wasnt possible?

It’s an interesting observation but, unfortunately, it’s not the reason. I’m not really sure how CIS decides which policies to make available during an alert, maybe there’s a bug here, but the email pre-defined policy only shows up if I run an email client, whereas the others are available for any application.

[attachment deleted by admin]

I allways make some own firewall predefined rules.
They show up.
Rules related to specificate the outgoing traffic.

I assume, an utorrent rule set would include ingoing traffic? If it was a rule about ingoing traffic, while an outgoing request fired the window in question, maybe thats the reason why an ingoing related rule set wasnt included in the possible answers?

On the test I just ran:

New Outbound only policy - available immediately from alert
New Outbound/Inbound policy - available immediately from alert
New Inbound only policy - unavailable from alert

Whilst two of the polices were made available from the alert immediately, all were available when adding a firewall rule manually. From what I can tell it doesn’t seem to matter if the application being added is on the TVL/safelist or not, the behaviour is the same.

Its good that no ingoing rule could be selected after an outgoing request triggered a question.

But what has been the content of the rule the OP made? Was it also an ingoing rule set? And if it has been a combined rule, what came first (on top)?

[quote author=clockwork link=topic=78548.msg562786#msg562786 date=1321654742]
Its good that no ingoing rule could be selected after an outgoing request triggered a question.[quote]

Good point.

An inbound only policy is available immediately when an inbound request is received, for example a web server. (image)

But what has been the content of the rule the OP made? Was it also an ingoing rule set? And if it has been a combined rule, what came first (on top)?

Makes no difference.

[attachment deleted by admin]