PPTP connection drops after a while

Hello,

After establishing a PPTP connection to a VPN, the connection drops after a while. This doesn’t happen when the Firewall Security Level is “disabled”, but happens on ANY other state. If needed, I could give you access to the VPN so that you could do your tests.

Thanks!

Can you please verify the Firewall logs to see if it records anything related to the tunnel traffic?

And one other thing you can try is to set “block fragmented IP datagrams” to unchecked.
Firewall, Advanced, Settings, Advanced.

I checked them, but unfortunately nothing appears.
I also tried unchecking the “block fragmented IP datagrams”, but the same occurs.

Thanks!

Are you using Microsoft PPTP software to connect to the VPN concentrator?

Can you verify if the Windows Event logs give any clue about why the connection is dropped?

Yes, I’m using the Microsoft PPTP Windows client. I’m on a Win7 64 bits.
I just cleared all Windows Event logs and established a new PPTP connection. I’m now waiting until the connection drops. Once it happens, I’ll check the events again and let you know.

BTW, the connection is not setup to automatically disconnect after being idle for X mins.

Thank you very much for your help!

After a few minues waiting (maybe 5-10 mins) the connection dropped. I went to the Windows Event logs and found the following entry:

“El usuario pc\Administrador marcó una conexión denominada VPN, que finalizó. El código de motivo devuelto es 829.”

My Windows is in Spanish. The message basically says that the user “Administrator” dialed a connection named VPN, which ended. The reason code returned is 829. It seems this error means that the modem (or other connecting device) was disconnected due to link failure.

So far, my tests indicate that, when the firewall is disabled, the connection is not dropped. I’ll do more tests with both the firewall on and off tomorrow morning my time, to see if I can confirm that the issue is related with the firewall.

An extra trace logging can be created by following this procedure:

RAS Logs

The logs need to be collected before you start the connection setup
Execute the following from elevated command prompt

• netsh ras set tr * en This enables logging
• - setup the connection and let it stay up till it disconnects automatically
• netsh ras set tr * di This disables logging

This will generate log files in the %windir%\tracing directory.

I have the logs. If you’re interested in any file in particular, let me know.

Just in case someone else is suffering this bug, I found the workaround:

  • Go to the Firewall settings and click on “Stealth Ports Wizard” and change the setting to “Alert me to incoming…”.

You won’t get any alert, but this fixes the issue. There must be some weird bug there.