PowerDVD 9 won't run under Comodo

I’m using Comodo version 3 build 531 on Win XP SP3

Power DVD9 won’t run when Defense+ Security Level is enabled at any level, including disabled. PowerDVD9 will crash upon starting producing a generic ‘…has encountered a problem and needs to close’.

The only configuration setting that I have found that allows PowerDVD9 to run is “deactivate Defense+ permanently”. I’ve tried all kinds of other configuration settings, too many to list here, but nothing else works.

Any ideas on how to get PowerDVD9 to run without deactivating Defense+?

Welcome to the forum Misha41 :slight_smile:
This topic might.

Thank you for the suggestion Dennis2. I looked at the thread you provided and unfortunately I’ve tried all those things mentioned. I have to agree with Woraws in that thread; only after deactivating Defense+ does PowerDVD9 (in my case) work.

I had a copy of Comodo 3.8 build 477 so I installed that, thinking it might resolve the issue but it did not, so I went back to the latest version of Comodo.

No changes I’ve made to any of the Defense+ settings resolves the issue. One thing that struck me as peculiar: PowerDVD9 files include several .imp files. When I try to add files with this extension as excluded from Image Execution Control or add them to My Own Safe Files for example they do not get added to the list. I don’t know if that means anything but I think it is peculiar.

A couple of things that bother me about Comodo (and indeed every firewall I’ve ever used that includes some type of HIPS) that I’ll mention. It’s a bit off topic but I think it’s important:

  • Disable certainly does not imply the same meaning as in the normal sense, i.e. if something is “disabled” it means it shouldn’t function. Clearly, “disabling” Defense+ does not stop all functionality.
  • Defense+ is to me obviously interfering with the proper functioning of PowerDVD9, since when Defense+ is “deactivated” PowerDVD9 works. What troubles me is that Defense+ provides absolutely no feedback to the user that it is doing something that is preventing the application from running properly. It took me about 6 hours of troubleshooting over several days to realize the problem lies with Defense+.

I noticed that I had to restart my system after I added PowerDVD 8 Ultra to exclude list (same problem as with 9).

Thanks for the suggestion. Unfortunately, I did restart after adding PDVD9 to the exclusion list but this did not rectify the problem.

put the powerdvd to the trusts.