Possible problem with CPF BETA and Shields up [RESOLVED]

OK, I went to shields up and ran their common ports scan and everything passed.

I then set CPF to allow all to see what ports my ISP blocks and of course CPF failed the test. I then set CPF back to custom but when I ran the test again it passed all the tests except ping reply. I shut down IE and tried again but it still failed the ping reply.

The only way I could find to fix this was to reboot.

Has anyone else tried this?

Yes this has been asked a couple of times before. Wait for 2 minutes without having any ICMP relatioship with that site and then retry. ICMP is handled specially in CPF. You an search the forum for a detailed expalanation.

Hey egemen, I did a search before posting but didn’t find anything.

Thanks for the quick answer.

Sure. ICMP is a bit different in CPF. 30 seconds to 2 minutes would take for CPF to adapt itself if there was a successful ICMP relationship with a host before.

It is required for stateful icmp inspection and for your network’s health. Nothing to worry about. For example, when you try to ping from another site like scan.sygate.com, it wont reply to ping requests during that time.

Thanks for the full explanation, I’ll mark this as resolved.

Thanks again and thanks for a great product. (R)