Possible Compatibiity Problem Between PretonSaver Home & CIS

Installed PretonSaver Home (a program to efficiently use printer ink and reduce consumption/cost). Preton is listed as a Trusted Vendor with Comodo. The install went OK, and there were no visible problems until I went into Comodo to verify my weekly AV scan. Once I clicked Antivirus > View Antivirus Events > More, I noticed that once I tried to click Tasks Launched, my mouse display went into a working mode and remain there until I clicked the window again and got the error message that CIS had stopped running and I was presented the options of continuing to wait or close the program. CIS does not fully close, just this particular window. This problem would activate itself no matter what I clicked inside the window. Same thing occurred using Firewall or Defense + to get to the same activity log page. I tried clicking the More Tab > Diagnostics, and no problems were indicated. I was unable to close the windows after the diagnostics for the same reason as described above. Second click of window triggered option to continue to wait or close. Close only closed that window and CIS remained open. When I reboot the computer, the Comodo tray icon appears and shows network activity, however, I’m unable to get into the program either by double-clicking or right-clicking the tray icon.

There are no log entries under Firewall or Defense + suggesting a problem. There were also no rules created during the install. I did notice that under the Defense + events there were a few instances of WerFault.exe showing up at about the same time I was installing Preton or attempting to access things in CIS.

I tried adding Preton’s active process to D+ Execution Control (since that has solved a couple of prior issues with MS Autoruns and jv16 Power Tools 2011). However, the problem remains.

Uninstalling PretonSaver Home fixes the problem immediately with respect to CIS operation.

Any suggestions on what to try to allow these two programs to live happily together?

Thanks. -SA Jack

Can you show a screenshot of the D+ logs? What do you mean with:

I tried adding Preton’s active process to D+ Execution Control


I’m assuming you want to see the creation of the Execution Control setting.

From Defense + tab > Defense + Settings > Execution Control Settings > Exclusions button > Add. I then chose the active Preton process that was running. Then applied the setting. I don’t have preton installed now to show you the listing in what I’ve described above. But when it was installed, there were no events showing under anything (AV, FW, D+), and no rule(s) created anywhere.

Thanks for the prompt reply. -SA Jack

Did the AV logs bring something to light?

All logs are clean with the exception of the WerFault.exe under D+ events that occurred either the time I installed Preton or was trying to interact with CIS with respect to this issue.

Thanks. -SA Jack

There is one thing that could be tried but that is academical as it is not installed: giving the program the Installer/Updater policy.

If that would not be helping I would suggest to file a bug report.