possible comodo bug or memeory corruption ? [Issue Report]

TOPIC TITLE
possible comodo bug or memory corruption ?


The bug/issue

  1. What you did: shceduled scans runs for a while
  2. What actually happened or you actually saw: BSOD appears - then i anlaysed minidump with kdfe program
    and it says :
    Crash date: Sun Aug 21 09:22:06.937 2011 (GMT+3)
    Stop error code: 0x1a_41284
    Process name: cmdagent.exe
    Probably caused by: memory_corruption ( ntMiLocateWsle+c1 )

it is likely that my memory is corrupted but BSOD happens at 99% of cases with above result of kdfe analysis
and for example malwarebytes completes scan without BSOD so i think this could not be a bug but perhaps some changes are possible to prevent this

  1. What you expected to happen or see:
  2. How you tried to fix it & what happened: i reinstalled comodo cis - no change in behavior
  3. If its an application compatibility problem have you tried the application fixes here?:
  4. Details & exact version of any application (execpt CIS) involved with download link:
  5. Whether you can make the problem happen again, and if so exact steps to make it happen: i start built in scheduled scan of comodo cis
  6. Any other information (eg your guess regarding the cause, with reasons):

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:
  5. Screenshot of More~About page. Can be used instead of typed product and AV database version.

Your set-up

  1. CIS version, AV database version & configuration used: avdb 9819 prod ver 5.5.195786.1383
  2. a) Have you updated (without uninstall) from CIS 3 or 4: no
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): no
  5. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV =
    D+=clean pc , Sand BOx = disabled , Firewall = Safe mode , AV = statefull
  6. OS version, service pack, number of bits, UAC setting, & account type:
    WIn XP, sp3 ,32 , Admin
  7. Other security and utility software installed:none rezident
  8. Virtual machine used (Please do NOT use Virtual box):

[attachment deleted by admin]

Thank you for your Issue report.

Moved to verified.

Thank you

Dennis