Possible Comodo/Avast Conflict. Why Do I have a problem Updating Avast?

I have had Avast Home as my Antivirus for some time now without any problem other than an occasional update would not load which I then did manually. For security on my PC also I have Comodo Firewall,Spybot S&D,AdAware, AVG Antispyware, Spyware Blaster installed, all up to date and used regularly.

This evening however, while my daughter who also has an account on this PC but not an administrative one was on Google the PC crashed. When it restarted I saw there were Windows Updates downloaded but not installed. i thought this was strange as I use the Automatic Update feature and it is set to 0600hrs daily. I installed them and on restarting I got the message that Avast had failed to update. I then tried to update manually but without success. I then found that my Internet connection was gone I restarted again but found that some of my startup programs had not loaded. I restarted again but although all programs had loaded this time Avast was switched off and I could not start it. I then got the following message.

“VPS file was destroyed. The scan completed with Error: 42040=VPS File was destroyed”.

I did not want to access the internet for advice without an anti virus so decided to uninstall Avast, restart PC and do a fresh install. This seemed to have worked until after updating and getting the message that Avast needed to restart my PC. On restart my PC booted up to the safe mode screen without being prompted by me. I then restarted again and although everything started ok this time I then got a news update from Avast and on exiting this I then got another message saying that Avast had to restart my system again. I declined that offer and as Avast seems to be working ok (7 provider(s) total, 6 running) I came here for some help or advice on whether all these restarts are normal behaviour.

I did a search on VPS File was destroyed, Error 42040 but found nothing.

It seems to me as if Comodo is not letting Avast update even though I have instructed it to do so.
On my Comodo Application Rules screen I have 4 listings for Avast.Could someone please check these settings and tell me if they are Ok.

Application-----Destination------Port-----Protocol----------Permission—Path---------Parent Path—Desc-

1avast.setup–Range 0-255 --0-65535-TCP/UDP in/out— Allow----avast.setup–ashServ.exe–update
2 avast.setup-----any------------any—TCP/UDP out--------Allow-----avast.setup–ashSimpl.exe-update
3 setup.ovr--------any------------any—TCP/UDP out--------Allow-----setup.ovr-----ashSimpl.exe-update
4 avast01.setup–any-----------any—TCP/UDP out------ Allow—avast01.setup–ashServ.exe-Unknown

Hopefully someone understands and can explain what this all means. thanks in advance.
Bluesjunior.