Possible CAVS Problem

I’m not sure if CAVS is the culprit here but have only noticed this problem since CAVS has been installed. Now and again when I login into WIndows, the system tray icons load but sometimes not fully and then the system is frozen. At this point, I have to do a hard reboot. Ocassionally, I may have to do this 2 or 3 times in a row before the desktop is loaded and other times there is no problem ???. Just thought I would mention this incase others (who have also installed CAVS) are experiencing this too.

:slight_smile:

There’s a known delay with the tray icons. I had it installed on mine and it would all of a sudden take an extra 5 minutes to load and the loading of the tray icons took ages. The next release will hopefully have resolved this issue. It’s going to be available in Beta tomorrow! and then the stable release will replace 1.1 fingers crossed a week later after going through a series of Release Canidates (RC’s).

Watch this forum for release notes and issues.

Eric

That’s good to hear, so CAVS is to blame >:( (only joking). I guess I should have given my system a little more time to load :-[.

:slight_smile:

Oh well, updated to 2.0.8.20 and it froze straight after installation :'(. It’s funny, RealVNC always seems to pop up first and then if nothing loads after, I know I’m in trouble ???. Left for a good 15 minutes and then tested with the caps lock key (no light) so hard reset. Came up ok on the second boot though :). Not sure how to tell if it’s a CAVS issue without un-installing CAVS which I don’t really want to do.

:slight_smile:

I’ve got the same problem, guys. I recently had to wipe my HD because of some other issues, and have just finished a clean reinstall of everything! So I thought now that the next Beta was out, I’d install that fresh on my computer. Once I logged in, that was it; the whole thing was frozen. No Task Manager, nothing. Had to hard reboot.

I uninstalled all other security software in Safe Mode, thinking that might be causing a problem. Didn’t fix it.

In Safe Mode, I disabled the UPSDBMaker from Startup. No joy.

Finally I disabled CMain from Startup, in Safe Mode. Then everything worked. Ran UPSDBMaker manually, no problem.

Reenabled CMain in Startup, everything froze again. Disabled it, Joy! Reinstalled the other security software, still no problems, as long as CAVS doesn’t start automatically.

So at present I will have to manually start CAVS from the icon. That seems to be working.

I never had this problem with any of the other Betas, so this (from my viewpoint) is something new; not an issue of load time/order, but of resources used during that load. Since this is a fresh system now, there’s very little loading at startup, to get in the way.

LM

If it helps, I don’t mind disabling the CAVS service and then enable once I’ve logged in each time (if that is what starts the system tray icon).

Edit: I see, startup as in registry. I got it.

:slight_smile:

Startup, as in Start/Run/msconfig/startup (tab)/uncheck CMain/Apply/Reboot. :wink:

I’ve added a link to this topic in Kishor’s bug reporting thread for the current Beta.

LM

Yep, same place. I just enjoy doing things the long and dirty way ;).

:slight_smile:

Even after removing from the registry, my desktop was still locking up :cry: (i.e system tray icons not loading). So I guess some other component of CAVS was involved. This had happened on the last four boots. I have now re-installed AntiVir and the last two boots have been successfull, so it’s looking like a CAVS problem :(. If there is anything that I can do to help in solving this problem, please let me know as I would like to continue using CAVS.

:slight_smile:

Graham1,

I used a free utility called StartRight (I got it on MajorGeeks) to control the startup order, and that seems to have worked nicely. Granted, it’s a workaround but it gets CAVS up and running.

I completely disabled CAVS (no startup, no service), and set up StartRight with load order for other applications.

Then I re-enabled CAVS. It still took a little while for everything to load the first reboot, but it worked.

Then I moved CAVS down in the load order, towards the bottom, so it’s last to come up. I didn’t space them out much; I only put 100 milliseconds between apps, but that seems to work, and doesn’t delay things too much.

If you want to use CAVS, that’s a way that may work for you.

LM

Thanks for your suggestion Little Mac :). I think I will wait untill Comodo resolve this issue.

:slight_smile:

I’m going to give this a try now, thanks :).

@Comodo Developers: Please, please, please fix this issue :'(. The last couple of days I’ve had to hardboot my laptop (compaq nx7010) 5 times (each boot) before I finally got to a working/usable desktop. If there are any logs or anything that I can forward to you to resolve this, please let me know.

:slight_smile:

Hi All,
Appologies on behalf of AV team.
This issues is being solved. And it will come next release. Till then pls disable on-access scanner deselect settings->On-access scan->“Enable at system startup”. Also disable HIPS.

Thanks & regards
Kishor

Thanks, will do :). So in the main window, “On Access Scanner” status = ON and “HIPS Application Control” status = OFF?

:slight_smile:

Seems to startup fine now, even with HIPS Application Control enabled :). Any idea when the update to fix this will be released?

:slight_smile: