Possible bugs with version

Hi egemen. I downloaded the last version and came accross with the following issues

  1. Subscription validity: Displays incorrectly greek characters.

  2. When I have disabled “comodo lanch pad” I noticed that:
    a) the system loads/boots with some delay
    b) probably interfears with the nvidia drivers of my video card. Monitor starts darker and becomes lighter after CPF is loaded. This also happens when CLP starts automatically but less time is needed to become lighter.
    c) probably interfears with the drivers of my via network card. Needs much more time to load the local connection icon in systray. This also happens when CLP starts automatically but less time is needed.

  3. When I check “Block all outgoing connections while booting” the network drivers won’t load and CPF initializes forever.

  4. CPF uses more memory than it did with the beta. 15-17 mb

I use Windows XP pro.

I’ve had a few BSODS “DRIVER_IRQL_NOT_LESS_OR_EQUAL” whilst creating rules “on the fly” with this version. Although I have seen one or two with previous versions. Ill see what files etc it relates to next time and check all my drivers are up to date.

Hi Steve, that type of error is usually from failing ram chip. When using certain apps, or just randomly, you may get this error and the BSOD. You may have a bad stick. Uninstall Comodo and run for a bit , do some normal usage tasks, see if it still shows up. My guess is though, it’s the ram. Perhaps why you see it with other versions as well. Higher usage apps will give you a BSOD. How much RAM do you have? Paging file size?



Hi Steve,

Thats very important. This happened while creating Network rules or Application rule or during an alert? Can you please check if you have memory dumps? Also what other security software do you have and OS ofcourse.


Happened during some new application alerts, creating a rule. BSODS are very random and not very often.

No memory dumps or event viewer errors (dumps are on), dont recall any files shown during BSODS.

XP Home, IE7 RC1, all windows updates (except WGA not.).
avast, spywareblaster and guard (BHO protection on only), ewido (on demand only), ad-aware se

Dell 3ghz P4 HT (no over clocking on CPU or graphics card)
512 ram
768-1536 virtual mem
ati x300 (latest and last drivers available for control panel version)

I intend on upgrading my RAM soon, replacing with 2x 1ghz.

IE7 often crashes (ntdll.dll), having seen M$ newsgroups, many BSODS are being reported with IE7 and/or recent windows updates.

I got that bsod when i first updated CAV 1.0 and that is the reason i dont use CAV

When you uninstall CPF, these BSODS stop?

I havent tried that. But I enabled Terminal Services and havent seen any BSODS since.

Just got a BSOD.

I changed Alert Freq. to High then, I removed IExplorer rules and restarted IExplorer to create new tighter rules. When I clicked on Allow it did a BSOD.

It only happens during rule creation so removing CPF would obviously stop it. After I rebooted I could create the rule without a BSOD.

How many application monitor rule do you have while having these issues? Can you please try to force your PC to create memory dumps?


45 app rules (alerts at High). I will try to get some memory dumps. The BSOD screen had no information.

I hope this falls under this thread. When ever I log off my wifes account and not just simply switch to mine. After it’s completely logged off, and I can click and log back onto my account, the Windows Security Warning Icon is in System Tray, but then quickly goes away on it’s own. I can only assume it is because Security Center isn’t recognizing Comodo Firewall for a split second as I don’t have time to click on it to read it. This doesn’t happen though, by just switching from one account to the other. It only happens if I completely log off her account first and then click on mine. I didn’t try it in reverse however. I hope I made this clear, and it was okay to post it here. I think this is may be a true bug, and not a possible one. Other wise I’m very happy with CPF at this time.

Since saturday I has 4 BSODs (2 today). I sent the minidumps to Comodo with the file send feature, but for now I uninstalled it.
The culprit is always cmdmon.sys (a Comodo driver). The 15th august I made a fresh XP installation after formatting, and had no BSOD before installing Comodo
Hope it will be corrected in the future. This firewall is very good.

Can you send screenshots to me here pls?


I send you screenshots from what WinDbg says.

[attachment deleted by admin]

Can you send me these memory dumps please? I have PMed my email to you.


Thank you very much for the memory dumps. According to the analysis, some parts of your RAM may be problematic. Can you try to test your RAM with http://oca.microsoft.com/en/windiag.asp

Let us know the results.


Hi Egemen,

Thank you for your advice. The Microsoft found sproradically an error in one of the test (memtest86 found nothing).
As the error was not lacated in one particulatr memory bank, I disabled the “turbo” setting in the BIOS and the errors disappeared. Spend a few hours to be shure. Happy to see Microsft made such a good test program.
Now Comodo is reinstalled. Hope no more BSODs.
But I find it stange that all the BSODs I got, were after Comodo installing and pointing to the Comodo driver.


I just got a bsod (IRQL_NOT_LESS_OR_EQUAL) a little while ago, which seems to involve cmdmon.sys. This is the first bsod I have experienced since installing CPF last friday. I will try that memory test software from Microsoft as well, but I can send you the minidump if you would like to have a look at it.

Apart from that, I have come across a weird issue: The application monitor is not blocking Internet Explorer (iexplore.exe) with a popup when I try to open a local web server running on the loopback interface ( and there are no existing application rules for IE. Other applications however, are blocked with a popup. The “Skip loopback TCP connections” setting is disabled, and I have also tried disabling “Do not show any alerts for the applications certified by COMODO”. But, if I also disable “Skip loopback UDP connections”, then I get a popup also for IE.

ok mine is not as bad as bsod but I’ve been frustrated for 24 hours and not sure what to do. After the update, my remote desktop over sshd stopped working and the rules still look ok. I’m lost. I even restored to my checkpoint 2 days ago and it’s still busted.

I limit my local lan to only port 22.

fyi now.