Ports are still blocked with Comodo Firewall on

Hello, I’m trying to solve this for very long time but I can’t figure it out.
When I want to share something on P2P network or run a online multiplayer game server I have to turn off Comodo Firewall because it is still blocking my ports.

So I do have port forwarding set at my router and when Comodo Firewall is turned off it works. Port check see that port as open.
But when I create application rule and even global rule for that port it isn’t open. Still when I turn on Comodo Firewall as Safe or Custom rules it doesn’t work.
I run out of any options. Can someone try to help me? Please.
What should I do to be one port opened in Comodo Firewall?

Setting a global rule allowing the destination ports seems to have solved it for me; dunno what might be happening with you.

It sucks though that I had to guess it was Comodo’s fault it was being blocked; there was nothing mentioned in the logs about the blocks and yet Comodo was still blocking :frowning:

check this: https://forums.comodo.com/firewall-help-cis/comodo-blocking-port-forwarding-t105501.0.html;msg766399#msg766399

Perhaps it might help