port scan blocking not working?


when I test my firewall on the grc port probing my firewall seems not working it should sense that there
should atlease a ddos flooding or port scan blocking but no response from the firewall and the scan result are port closed and not stealthed. What seems to be the problem?

by the way im using a wifi connection and from that site it scan different IP address not the one that I have here in my PC


Three questions: do you use a router? Have you set up a network zone for your computer and trusted IP’s (like your LAN or other trusted IP’s like the multicasting IP’s)? And are you using a cable modem or ADSL? These questions affect your questions. BTW, what IP does the scan report and what IP were you expecting it to report? If you expected the LAN IP ( for example) - that is an address range reserved for local networks.

Hi anotherone,

Thanks for your reply, I am not using a router I’m using only a single desktop pc that has a WIFI subscription.(antenna base)

In a DOS shell, run the following command:

ipconfig /all

What IP address is reported for your host? Then go to:


to see what it says it your IP address. Are they the same?

from my pc’s ip address is 192.168.x.x while i had been read from probing site as 125.60.x.x

The address is just in the default Home LAN range of addresses. The IP address that is being scanned is the variable address that is dynamically assigned to you by your ISP. I believe that it changes with every connection, although there is a chance that you might get assigned a second time.
As for the ports closed but not stealthed, you need to define your network zone. If you see an address for your LAN using ipconfig, then that should be used to define the Home Zone in the My Network Zones section. As an example, if you have a machine address of and a subnet mask of, define the home IP range as to With that defined, run the Stealth Ports Wizard and select the first option and then click the drop-down on the empty box below. Your home network will appear there and you should use it to define the Safe Zone.

Your computer has an internal IP address assigned to you by your NAT (network address translation) router. What GRC sees is the WAN-side IP address of your router. If you were using only a router with no NAT, or if you were directly connected to your ISP’s Internet connection (i.e., directly to the cable modem) then GRC would’ve seen your computer. Right now, GRC sees your NAT router, and the firewall in your NAT router isn’t configured well enough to stealth the ports. GRC never even gets to your computer.

Read their FAQ at http://www.grc.com/faq-shieldsup.htm#NAT.

You will need to use the URL to the web server embedded in your NAT router to configure its firewall. Not always but often you go to to get to the NAT router’s web server. Also review the manual that came with the router to figure out how to get to it from your internal host and how to configure it.

well atleast I know now that the NAT ip are scan and not my PC directly. so I should say that it is better to have it that way. much safer that scanned directly. :Beer thanks man! :Beer