Port Forwarding for Utorrent isn't working [RESOLVED]

Hey fellas,

I’ll start with the basic specs:

Comodo 5.3
Windows 7 Pro updated (defender disabled)
Utorrent 2.2.1
DSL (5mb down, 500k up)

This is what I’ve tried so far:

  • I created a global rule to allow 21752
  • Utorrent is a trusted program in the firewall and Defense+ settings.
  • Stealth ports wizard is set to case basis
  • Firewall behavior settings are on safemode
  • Even tried creating a rule in predefined policies

despite this utorrent’s own test shows the port as blocked. External port scan also reveals 21752 as stealth. I’m getting horrible download speeds right now (capped at >20kbps). Any suggestions?

hey and warm Welcome to comodo forums!

try to put the firewall on training mode when you’re running Utorrent for a few min.

Regards,
Valentin N

tried it, didn’t work : /

The one thing (and the most important thing) missing from your list is wheher you have forwarded port 21752 on your router to the IP address on the system running Utorrent?

Until this is done, anything you do in CIS is irrelevant.

The data stream has to be able to get past your router before you have to worry about CIS.

Hope this helps,
Ewen :slight_smile:

: )

worked !!

Thanks

I was thinking this, Ewen. You beat me to it.