Port 520 of extended file name server failed!

After I successfully updated my CIS to version 5.4.189068.1354 yesterday, I ran firewall test on GRC | ShieldsUP and it found only one port 520 that was closed and not stealth. The port 520 belongs to extended file name server and not to router. I still do not know how to make the port 520 stealth :THNK. I tried Stealth Ports Wizard in CIS but fruitless.

Again, I tested only one port 520 on GRC | ShieldUP and it created textual summary as show below:

GRC Port Authority Report created on UTC: 2011-05-05 at 10:52:21

Results from probe of port: 520

0 Ports Open
1 Ports Closed
0 Ports Stealth

1 Ports Tested

THE PORT tested was found to be: CLOSED.

TruStealth: FAILED - NOT all tested ports were STEALTH,
- NO unsolicited packets were received,
- NO Ping reply (ICMP Echo) was received.

Only Solicited TCP Packets: RECEIVED (FAILED)

For your information:

Computer: Laptop - Dell Inspiron 1545
My laptop is connected with cable to Wireless Router NETGEAR DGN2200 with built-in modem
Network Card : Marvell Yukon 88E8040 PCI-E Fast Ethernet Controller
Operating System : Windows Vista ™ Home Basic Home Edition 6.00.6002 Service Pack 2 (32-bit)
(I never cleaned up registry.)

Security applications:

Comodo Internet Security (without anti-virus)
avast! Free Antivirus
Windows Defender
Secunia PSI (
Sandboxie 3.54 (32-bit)

Firefox 4.0.1:

Adblock Plus

Please help me how to make the port 520 stealth successfully. Please give me clear step by step directions.

Thank you,
mrerk ;D

If you have a router; Without DMZ Enabled then it’s still testing your router, Not your PC

Kind Regards