port 113

hello, how to config mIRC rule to got an ident response?
i set mIRC allow any ip tcp in / source port 113 and destination port any
then source port any and destination port 113 but it doesnt work.
i dont know how to set the firewall to got an ident response, if anyone can help me, thanks.

I don’t use mIRC so i’m not sure , but I know many routers have a setting that filters port 113. If thats not it, then I’m sure another member that uses mIRC will post back with some rule help.

Most security devices protect this port, due to many malicious intents. Check your router, firewall, (even antivirus some filter pots.)

port 113 is open on my router, my AV doesnt check port 113.
the prob is that i don’t know how to set comodo to allow port 113 for mIRC on vista.
it works on xp cause i don’t use comodo on it, i use online armor and allow port 113 so the server recognize my ident when i connect to irc server. i just don’t know how to set comodo on vista to allow ident on port 113.

The quickest way to do this is to set mIRC as an allowed and trusted application.

Go into the firewall settings and do Trusted Application, or something to that effect, and add mIRC. CPF will then allow all incoming and outgoing traffic for that application. Or simply stick D+ and the firewall module to Learning Mode, run mIRC, if it works then stick D+ and the firewall module to what it was before.

ok thanks, D+ is allready in training mode, i’ll do that with the firewall then launch mirc to see if it works.

update : i tried in training mode but it seems the ident respons doesnt work.
i try with firewall off but it doesnt work too.
strange, maybe it comes from vista?
i tried with kaspersky OFF too, it doesnt work.
don’t know where to look now.
anyway thanks for your help.

Hmm. Please make sure windows firewall is disabled. If so, run mIRC as admin. Right-click on mIRC, and hit ‘run as administrator’ see if that works.

no it doesnt work better.
maybe i have to set port 113 in “My port sets” in the comodo firewall ?
what are priviliged ports? in [0-1023]

My mIRC runs on port 6667 Not sure if this helps any but by default it connects via 6667 atleast in mIRC 6.16 it does.

and when i set firewall to training mode the firewall never said mirc is trying to connect port 113 tcp in.
comodo got rules to prevent any tcp in from port 113?
ans yes in general irc server are connected to port 6666-6667-etc
but it’s not the same thing as ident response. some servers need an ident response to recognize u and allow u to connect to their servers, like efnet london.

update : i tried with comodo uninstalled, it doesnt work too, so it doesnt come from comodo, it’s a prob with vista.
anyone knows what can block port 113 in vista? the vista FW is off and kaspersky AV doesnt control port 113.