pop up boxs for copying files

when I copy a file to my thumb drive, comodo firewall pop a box asking if I allow the action

I copy files back and forth between my pc and thumb drive, and I don’t want to see this box every time, how can I disable it?

Well, the thing is that it’s explorer.exe copying/moving etc. files, unless you are using application as TotalCommander, so you don’t want to disable this permanently but only for this copying purpose. I would suggest to select Treat as Installer/Updater in the first pop-up and then accept switching to Instalation mode temporarily.

That probably happens when you copy executables (exe, vbs, stuff like that), as they are included in My Protected Files by default. If this is the case, then you could get rid of the alerts by setting your application’s (which probably is explorer.exe) default action for Protected Files/Folders access to “Allow”. It can be done in Defense+ / Advanced / Computer Security Policy / [Your application’s executable] / Access Rights.