Pogo.com and Connection Errors

Hi.
This is probably easily fixed but i figured it would be quicker to ask you guys/girls here rather than go through everything slowlllly myself…
Right ! Last night i installed the latest Comodo and it was doing great, learning and configging, it even did my p2p and i didnt need to do a thing :smiley: other than OK it.
Anyway i went onto pogo.com and played a few games with my girlfriend and suddenly the page froze and pogo said " possible firewall conflict"
So what do i need to do here ? I know pogos java based, but thats it.

Also once during play Comodo disconnected my Livebox router/modem. !!! :o

Thanks. :wink:

OK dont worry i have uninstalled comodo. Its not stable enough yet.

A few more details would help - browser used, is there a separate application for Pogo or is it browser based. Also, is your router wired or wireless? There is info on the Pogo site:
Answer

Pogo does not officially support connections through firewalls, routers, or proxy servers. Also, please note that wireless Internet always has wireless routing, which can potentially block Pogo.

There are some things you can do to improve your ability to connect to Pogo if you do have a router or firewall. There is a fairly simple solution which most firewall packages support. If you allow access via our class C licenses, you will then be able to access the games and everything should work fine. Your firewall will probably require some IP addresses for this, and here are the IP addresses you need:

*
  159.153.235.1
*
  159.153.235.2

From this, it may be your router that is causing the problem, but it is impossible to tell without a lot more detail. It is really a shame that you have already removed CFP, because if it was blocking a connection, there would be info in the Firewall Event log, listing the blocked connection, protocol, ports etc. The Java based interface with pop-up windows and so on is fine for that site, but it is a real hazard if you happen to browse to a hostile site with Java enabled. Perhaps you use Firefox with Noscript?

Thanks for the info.

Pogo works fine with my router. I dont know why comodo didnt work out , the disconnections finished me for now ,thats not to say i wont go back to it :wink:

Please understand something from the get go. If CPF3 blocked pogo, I would not be alive and posting
because my wife would have killed me. But as I type this, my wife is happily using pogo and CPF3 with zero problems on the other computer on my lan.

Given this anomaly between my results and the results of poutine, its not time to poo poo or doubt either me or poutine. But it is time to find out why CPF3 blocks pogo on some computers and not on others.

In terms of getting help from pogo, its almost a total forget it exercise in futility.

But I do have a theory that may or not be right. I had earlier posted that theory with zero feedback to confirm or deny if I was right or wrong.

My theory is that pogo.com and CPF3 will not work well together with java versions earlier than JRE
6.0.28 and java is now up to java 6.0.3. And the other point is that installing a newer version of java is only half the job, because one should use add and remove programs to uninstall earlier versions.

So I will ask pouline or anyone having pogo problems with CPF3 to try updating java and post back to see if the pogo problems go away.

Here is one link to the latest java–Download Java Runtime Environment 32-bit 8 update 341 for Windows - Filehippo.com

If you want a guess, I would imagine that the browser on the system that works was configured by clicking Accept on the first pop-up and the one that does not work had the browser (or whatever is used to play at Pogo) configured as Web Browser using the “Treat this program as…” box on the pop-up. The latter is more secure, but the Allow option leaves the communications wide open - All IP addresses and all ports both in and out. It would be much safer to configure the browser using the default Web Browser configuration and add an Allow rule for the Pogo site: 159.153.235.1 and 159.153.235.2
I don’t know what protocol is needed, but you can just use IP since the Allow rule is site-specific and you can’t specify ports anyway - they use random ports. The rules needed would look like this:
Allow
IP
Out
Source IP Any
Destination IP (range: 159.153.235.1 - 159.153.235.2)
Details Any

and

Allow
IP
In
Source IP (range: 159.153.235.1 - 159.153.235.2)
Destination IP Any
Details Any

This would be added to the rule for your browser (if that is what is used to play at Pogo) as listed in Firewall>Advanced>Network Security Policy>(locate and select the program used)>Edit. If the program uses a Predefined Policy, change that choice to “Use a Custom Policy” and click the “Copy from” button and select the Predefined Policy that was previously applied (if it is a browser, then the Web Browser policy should be chosen) - that allows you to edit the rule without having to change the Predefined Policy. With the Custom Policy chosen, then click Add and enter the two rules above.

To AnotherOne,

Please understand that I have no problem with your suggestion that may or may not work. But two points to make.

  1. Even if your fix works for everyone who sees it, most CPF3 users will not see it. In my case I don’t need your fix because I get no conflicts with pogo.

  2. Intermittent problems affecting some computers and not others are the hardest to troubleshoot. And given the passions of some pogo users, it becomes important to find the root cause. While I am not wedded to my one theory as the holy grail, until the root cause is found it can’t be corrected by comodo programmers.

Ok. well seems there could be an issue with pogo, We play dominos on there :smiley: thats all. ! but thats not a huge concern to me. (well not yet …were too busy with New Year etc) What is however is that Comodo kept disconnecting my router/modem. I dont understand how it does that.
Any fix ? Thanks.

I havent given you much details either have i, shame on moi !!!
XP Pro Service pack 2 . Internet Explorer 7. NOD32. V.3.621. JAVA Version 6 Update 3 (latest)

Everything worked great with Comodo except pogo and the fact it kept diconnecting my router/modem. I played dominos for about 5 minutes with CPF running, then “BOOM” A Pogo page loaded and said " your firewall might be blocking…blah blah…"

If poutine is using the latest java, there goes my hypothesis about it being older java versions.

Ahh well, im still watching this thread closely, comodo ran really nicely and i would use it again.
It also blocked my speed test on thinkbroadband.com until i ticked “use port 80”

I will come back every day or so and read all your tips.
Thanks guys.

Hmm,
might try it again, i just imaged my drive.
Not sure about configging it for thinkbroadband or pogo though, ill use Anotherones settings.
We’ll see.

Because I am somewhat interested by troubleshooting questions, I did check pogo help on firewall issues. And the pogo help files confirmed that pogo ip addresses are supposed to be 159.153.235.1or 2 just like AnotherOne said they were suppose to be. But just to test, I went start–run–cmd–ping 159.153.235.1 and got no reply connection timed out, 4 of 4 attempts. And tried again with CPF3 set to disabled with the same results.

Next I went start–run–cmd–ping pogo.com and found sneaky ole pogo replied 4 out of 4 times to a new ip address of 159.153.236.12. So the AnotherOne advice may be valid if the new ip address is used.

The other information on the pogo help site is that pogo.com is not port specific so opening or closing hardware router ports may not be productive solution. But I now wonder if the poutine problem is in different dns translations between CPF3 and his hardware router. And could a firmware upgrade of the router be called for?

But given this is a problem for just some users and not others, if pogo is going to play musical chairs with IP addresses without updating its help files, all fixes along these lines may be temporary at best.

Hi Osage.
My firmware is up to date to, i keep every element updated (a habit as its my job to test and troubleshoot computer systems.;)) I’m just not used to Comodos little intricacies yet !
By the way i reinstalled comodo on a fresh image tonight, disabled NOD V.3 this time and rebooted. After the sys restarted i let CPF Defense+ find pretty much all i had installed, then ran through the
connection settings. Blocking some apps, allowing others.
I have to say that tonight i didnt have any disconnections, pogo played flawlessly and thinkbroadband wasnt blocked either.
It appears that (so far) all is well and CPF is behaving like a champ. :smiley:

The system should configure itself with your Allow and other pop-up options. People have problems sometimes when a web site wants to use your browser in a non-standard way. Most web sites just load pages or download software/data/music/video. This is done on a set range of ports. Pogo want to use changing ports and their web page identified a couple of addresses to use (I would just Add the 159.153.236.12 address, using a separate In and Out rule, to the other two - who knows if they don’t use those addresses also). The only problem with the automatic configuration method is when a web browser is configured. If it is configured with the Allow option, the permission is too broad to be safe. If it is configured with the “Treat this program as…” option, choosing the Web Browser policy, it is restrictive enough to be safe, but it also does not have permissions for oddballs like Pogo that want different permissions from the usual. That’s when you have to start writing Allow rules. One thing that worried me last night was I forgot to sya that you have to have the Block and Log rule last. If your new rules are after it, they will be prevented from working by the Block rule which is applied before them.

If pogo’s working OK now though, surely l i dont need to do a thing though do i ? ???

Actually i just found out that Comodo lets far too many apps have net access !!! I dont like that , my main use of a FW is to not allow apps access to the internet. !!!
The fact it allows without asking makes it pretty useless for my needs. I’m sure others must have found this out to. Aww well. Better luck next time CPF.

There is a “Safe” list of applications that are known and don’t allow other software to exploit their internet connection. This list is maintained by Comodo and is being expanded as a way of identifying malware by white listing. If there are programs that you specifically want to limit that are on that list, you would have to write a Block rule for that program.

Its a nice idea what they are doing but i dont think im alone in saying most users want to be in control of whats allowed or blocked. Yeah its easy to create a block rule, but also when you open an app and it tries to connect, most FW’s will tell you which part of the app is trying to connect.
Some complex programs can contain 7 or more exes. I’d have to block each. Sorry but this isnt acceptable for my requirements. Other than that though it rocks.

You can block all application in a folder using the method here:
https://forums.comodo.com/help_for_v3/how_to_block_the_access_to_an_entire_folder_content-t17871.0.html;msg121953#msg121953

Yeah thats good :wink: So Comodo will go back on my Sys Again.
Thanks AnotherOne.