Please verify with Netalyzr: outbound fragmented UDP traffic is blocked[v6]

Hi all,
Think I may have found another small bug. But do please verify first before I put in into a bug report.
You will need Java enabled for this yes (I know, Java) and run the test at http://netalyzr.icsi.berkeley.edu/

For the UDP test I got following remark ONLY when running the test with CIS firewall active. Regarding relevant settings,
“Do protocol analysis” and “Block fragmented IP traffic” are unchecked.

[i]Basic UDP access is available.
The client was unable to send fragmented UDP traffic. The most likely cause is an error in your network’s firewall configuration or NAT.
The maximum packet successfully sent was 1472 bytes of payload.

The client was able to receive fragmented UDP traffic.[/i]

So I would expect Comodo should have allowed outbound fragmented UDP traffic. Moreover, please check the firewall log. I’ll post a screen shot when I get in front of the Comodo equipped workstation, however, the log is stating that INCOMING UDP traffic is being blocked.

Sorry cannot run that at the moment - possible Java version incompatibility? So could you please make a bug report anyway, including the netaliser output.

(N.B. All us mods are volunteers so I’m sorry but we don’t have the time to make something like the above work if it doesn’t straight away).

Best wishes

Mouse


Thank you very much for your issue report.

We would very much appreciate it if you would be kind enough to edit your report to put it in the standard format and add any additional information requested, as this will make it much easier for the developers to diagnose and fix the problem.

The reasons we need all the information in the format, though they may not seem directly relevant to the issue are explained here.

If you are able to do this we will forward this post to the format verified board, where it is more likely to get looked at by developers. You can find assistance using red links in the format and here. If you need further help please ask a mod. If you do not add the information after a day or two we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report in standard format or not. However we may remind you if we think a bug of particular importance.

Many thanks again

Mouse

No worries I will. Will probably not get around doing it today. If you are using Firefox, in the latest version (at least in version 18) Java is not activated explicitly.

If you have time, please refer to this screenshot
http://news.pogo.com/how-to-enable-java-if-its-been-blocked-by-firefox/

For FF, this needs to be done on 2 occasions for Netalyzer. Once on the page where the start link is, and a second time on the page where the survey is (this 2nd page actually starts the test).

Valuable info. Why the dickens would they do this without telling users…

PM sent

Just FYI on this; first time I ran the test on my system, I got the fragmented UDP results; BUT ever since then I do not get this - UDP can send and recieve fragmented packages. Might this actually have something to do with Java permissions not fully ‘in play’ during the first test?

Java have sorted the install problem now, so I’ve run the test.

I get UDP Connectivity = OK, no mention of fragmentation.

I’m using Win7 SP1 x64, connecting PPOA through a Broadcom NetLink Gigabit Ethernet wired internet card, homeplugs, and a Netgear DG834v4 router with DGteam firmware.

CIS FW is at standard proactive settings apart from some global and apps rules. Windows FW is off.

Mouse

Thanks very much for your issue report, which is much appreciated.

We have moved it to the non-format bugs board for the moment, because it is not in the standard format or too much of the information we normally need to replicate a problem and fix it is still missing.

We realize some people may not have the time to do an issue report in standard format, and therefore offer the option of a non-format report instead. But the problem is much more likely to be fixed promptly if you edit your first post to create an issue report which reflects the guidance in the Standard Format topic. (You can copy and paste the format from this topic). The reasons we ask for the information we do are given in this post.

You can get your report moved to the format verified issues board simply by ensuring that it reflects the guidance in the standard format topic, and PM’ing a mod who is active on the bug board.

Best wishes

Mouse

Can you please check and see if this is fixed with the newest version (version 6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Also, note that all bug reports in the Non-Format section of the forum, which is where this report currently is, are not looked at by the devs. Thus, if the bug you were experiencing is still not fixed please edit your first post so that it is in the correct format (found here, with all required attachments, so I can forward this to the devs and get this problem fixed.

Thank you. PM sent.

From the above comments, and lack of response, I am assuming that this is fixed.

I’ll move this to Resolved.