Please help Comodo blocked Windows. Now can't run any apps anymore [RESOLVED]

I was running a procedure to clean the system (UPDATED 3-Step Virus/Spyware/Malware Removal Instructions | TechSpot Forums)…

I run SmitFraudFix in SAFE MODE, then in NORMAL MODE I
run its option number 5: about remove the DNS Hijacks.

Then I run Vundofix and COMMODO Firewall PRO stopped
it. I told it to run it as an “isolated application”,
but nothing.

I run COMMODO Firewall PRO settings and created “a new
trusted application”, browsing towards the Vundofix
file… and there the Chaos!

The mess!

Any application I launch… I hear the error sound
and a message that tell me (translated from
italian…) about: “it isn’t a Win32 valid

I can’t run NOTHING!

I shutdown the COMMODO Firewall.
Tried to re-launch: SAME ERROR!

I powered off the computer.
Power on: boot: it doesn’t run the COMMODO Firewall at
startup and also other apps… I click on any icon:

I can’t modify COMMODO Firewall’s settings now:
because it is not launched, even if I restart the
computer, and if I try to launch or uninstall it, I
get the same error!

Windows become totally useless!

Please help me.

Thank you very much.

NEWS: I can only run Comodo Firewall if I boot windows in SAFE MODE!

Somewhere along the line there has likely been an inadvertent isolation of wininit.exe or explorer.exe which launch the other processes. The only solution we have found is to go to safe mode and uninstall Comodo Firewall, then reinstall. Not exactly a bug, but certainly an undesirable characteristic; don’t know where a solution might be in the wish list priorities. :frowning:

Excellent Idea Sded, thank you very much!

I launched the uninstall of comodo firewall under windows safe mode and rebooted: it works. I reinstalled the comodo firewall. :BNC

I’ll try to pay more attention in future.